summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-3.10/623-MIPS-ath79-DIR505-support.patch
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2013-08-05 10:41:48 +0000
committerJohn Crispin <john@openwrt.org>2013-08-05 10:41:48 +0000
commit553a46972830d8a0eff4265eed150da49f050634 (patch)
treea1b42e790c5a664bd36443ac16448d6eaaf2f8e4 /target/linux/ar71xx/patches-3.10/623-MIPS-ath79-DIR505-support.patch
parent6743f2625b854cd45d253e289844524c99584777 (diff)
downloadmaster-31e0f0ae-553a46972830d8a0eff4265eed150da49f050634.tar.gz
master-31e0f0ae-553a46972830d8a0eff4265eed150da49f050634.tar.bz2
master-31e0f0ae-553a46972830d8a0eff4265eed150da49f050634.zip
ar71xx: add support for dir 505 a1
this patch is based on ... -> https://forum.openwrt.org/viewtopic.php?pid=179902#p179902 Signed-off-by: John Crispin <blogic@openwrt.org> SVN-Revision: 37703
Diffstat (limited to 'target/linux/ar71xx/patches-3.10/623-MIPS-ath79-DIR505-support.patch')
-rw-r--r--target/linux/ar71xx/patches-3.10/623-MIPS-ath79-DIR505-support.patch45
1 files changed, 45 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-3.10/623-MIPS-ath79-DIR505-support.patch b/target/linux/ar71xx/patches-3.10/623-MIPS-ath79-DIR505-support.patch
new file mode 100644
index 0000000000..ee41f655cc
--- /dev/null
+++ b/target/linux/ar71xx/patches-3.10/623-MIPS-ath79-DIR505-support.patch
@@ -0,0 +1,45 @@
+Index: linux-3.10.4/arch/mips/ath79/Kconfig
+===================================================================
+--- linux-3.10.4.orig/arch/mips/ath79/Kconfig 2013-08-04 19:08:12.739921385 +0200
++++ linux-3.10.4/arch/mips/ath79/Kconfig 2013-08-04 19:09:15.379922883 +0200
+@@ -254,6 +254,16 @@
+ select ATH79_DEV_USB
+ select MYLOADER
+
++config ATH79_MACH_DIR_505_A1
++ bool "D-Link DIR-505-A1 support"
++ select SOC_AR933X
++ select ATH79_DEV_ETH
++ select ATH79_DEV_GPIO_BUTTONS
++ select ATH79_DEV_LEDS_GPIO
++ select ATH79_DEV_M25P80
++ select ATH79_DEV_WMAC
++ select ATH79_NVRAM
++
+ config ATH79_MACH_DIR_600_A1
+ bool "D-Link DIR-600 A1/DIR-615 E4 support"
+ select SOC_AR724X
+Index: linux-3.10.4/arch/mips/ath79/Makefile
+===================================================================
+--- linux-3.10.4.orig/arch/mips/ath79/Makefile 2013-08-04 19:07:36.299920522 +0200
++++ linux-3.10.4/arch/mips/ath79/Makefile 2013-08-04 19:09:42.363923523 +0200
+@@ -53,6 +53,7 @@
+ obj-$(CONFIG_ATH79_MACH_AW_NR580) += mach-aw-nr580.o
+ obj-$(CONFIG_ATH79_MACH_CAP4200AG) += mach-cap4200ag.o
+ obj-$(CONFIG_ATH79_MACH_DB120) += mach-db120.o
++obj-$(CONFIG_ATH79_MACH_DIR_505_A1) += mach-dir-505-a1.o
+ obj-$(CONFIG_ATH79_MACH_DIR_600_A1) += mach-dir-600-a1.o
+ obj-$(CONFIG_ATH79_MACH_DIR_615_C1) += mach-dir-615-c1.o
+ obj-$(CONFIG_ATH79_MACH_DIR_825_B1) += mach-dir-825-b1.o
+Index: linux-3.10.4/arch/mips/ath79/machtypes.h
+===================================================================
+--- linux-3.10.4.orig/arch/mips/ath79/machtypes.h 2013-08-04 19:08:12.739921385 +0200
++++ linux-3.10.4/arch/mips/ath79/machtypes.h 2013-08-04 19:09:29.715923222 +0200
+@@ -37,6 +37,7 @@
+ ATH79_MACH_CARAMBOLA2, /* 8devices Carambola2 */
+ ATH79_MACH_DB120, /* Atheros DB120 reference board */
+ ATH79_MACH_PB44, /* Atheros PB44 reference board */
++ ATH79_MACH_DIR_505_A1, /* D-Link DIR-505 rev. A1 */
+ ATH79_MACH_DIR_600_A1, /* D-Link DIR-600 rev. A1 */
+ ATH79_MACH_DIR_615_C1, /* D-Link DIR-615 rev. C1 */
+ ATH79_MACH_DIR_615_E4, /* D-Link DIR-615 rev. E4 */