summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-2.6.39/206-nxp-74hc153-gpio-chip-driver.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2011-06-29 08:57:32 +0000
committerGabor Juhos <juhosg@openwrt.org>2011-06-29 08:57:32 +0000
commit6627574e57a612e5e901317224b0910d28835e19 (patch)
tree486df91424f83a929f1f506cb2bd74f04788f7f8 /target/linux/ar71xx/patches-2.6.39/206-nxp-74hc153-gpio-chip-driver.patch
parent1e138098cd5760285fe70961760d62e98b16852a (diff)
downloadmaster-31e0f0ae-6627574e57a612e5e901317224b0910d28835e19.tar.gz
master-31e0f0ae-6627574e57a612e5e901317224b0910d28835e19.tar.bz2
master-31e0f0ae-6627574e57a612e5e901317224b0910d28835e19.zip
ar71xx: add 2.6.39 support
SVN-Revision: 27310
Diffstat (limited to 'target/linux/ar71xx/patches-2.6.39/206-nxp-74hc153-gpio-chip-driver.patch')
-rw-r--r--target/linux/ar71xx/patches-2.6.39/206-nxp-74hc153-gpio-chip-driver.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-2.6.39/206-nxp-74hc153-gpio-chip-driver.patch b/target/linux/ar71xx/patches-2.6.39/206-nxp-74hc153-gpio-chip-driver.patch
new file mode 100644
index 0000000000..128b3a5da8
--- /dev/null
+++ b/target/linux/ar71xx/patches-2.6.39/206-nxp-74hc153-gpio-chip-driver.patch
@@ -0,0 +1,26 @@
+--- a/drivers/gpio/Kconfig
++++ b/drivers/gpio/Kconfig
+@@ -419,4 +419,13 @@ config AB8500_GPIO
+ depends on AB8500_CORE && BROKEN
+ help
+ Select this to enable the AB8500 IC GPIO driver
++
++comment "Other GPIO expanders"
++
++config GPIO_NXP_74HC153
++ tristate "NXP 74HC153 Dual 4-input multiplexer"
++ help
++ Platform driver for NXP 74HC153 Dual 4-input Multiplexer. This
++ provides a GPIO interface supporting input mode only.
++
+ endif
+--- a/drivers/gpio/Makefile
++++ b/drivers/gpio/Makefile
+@@ -18,6 +18,7 @@ obj-$(CONFIG_GPIO_MAX7301) += max7301.o
+ obj-$(CONFIG_GPIO_MAX732X) += max732x.o
+ obj-$(CONFIG_GPIO_MC33880) += mc33880.o
+ obj-$(CONFIG_GPIO_MCP23S08) += mcp23s08.o
++obj-$(CONFIG_GPIO_NXP_74HC153) += nxp_74hc153.o
+ obj-$(CONFIG_GPIO_74X164) += 74x164.o
+ obj-$(CONFIG_GPIO_PCA953X) += pca953x.o
+ obj-$(CONFIG_GPIO_PCF857X) += pcf857x.o