summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-2.6.39/200-rb4xx_nand_driver.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2011-06-29 08:57:32 +0000
committerGabor Juhos <juhosg@openwrt.org>2011-06-29 08:57:32 +0000
commit6627574e57a612e5e901317224b0910d28835e19 (patch)
tree486df91424f83a929f1f506cb2bd74f04788f7f8 /target/linux/ar71xx/patches-2.6.39/200-rb4xx_nand_driver.patch
parent1e138098cd5760285fe70961760d62e98b16852a (diff)
downloadmaster-31e0f0ae-6627574e57a612e5e901317224b0910d28835e19.tar.gz
master-31e0f0ae-6627574e57a612e5e901317224b0910d28835e19.tar.bz2
master-31e0f0ae-6627574e57a612e5e901317224b0910d28835e19.zip
ar71xx: add 2.6.39 support
SVN-Revision: 27310
Diffstat (limited to 'target/linux/ar71xx/patches-2.6.39/200-rb4xx_nand_driver.patch')
-rw-r--r--target/linux/ar71xx/patches-2.6.39/200-rb4xx_nand_driver.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-2.6.39/200-rb4xx_nand_driver.patch b/target/linux/ar71xx/patches-2.6.39/200-rb4xx_nand_driver.patch
new file mode 100644
index 0000000000..53c4db2998
--- /dev/null
+++ b/target/linux/ar71xx/patches-2.6.39/200-rb4xx_nand_driver.patch
@@ -0,0 +1,21 @@
+--- a/drivers/mtd/nand/Kconfig
++++ b/drivers/mtd/nand/Kconfig
+@@ -531,4 +531,8 @@ config MTD_NAND_FSMC
+ Enables support for NAND Flash chips on the ST Microelectronics
+ Flexible Static Memory Controller (FSMC)
+
++config MTD_NAND_RB4XX
++ tristate "NAND flash driver for RouterBoard 4xx series"
++ depends on MTD_NAND && AR71XX_MACH_RB4XX
++
+ endif # MTD_NAND
+--- a/drivers/mtd/nand/Makefile
++++ b/drivers/mtd/nand/Makefile
+@@ -34,6 +34,7 @@ obj-$(CONFIG_MTD_NAND_CM_X270) += cmx27
+ obj-$(CONFIG_MTD_NAND_PXA3xx) += pxa3xx_nand.o
+ obj-$(CONFIG_MTD_NAND_TMIO) += tmio_nand.o
+ obj-$(CONFIG_MTD_NAND_PLATFORM) += plat_nand.o
++obj-$(CONFIG_MTD_NAND_RB4XX) += rb4xx_nand.o
+ obj-$(CONFIG_MTD_ALAUDA) += alauda.o
+ obj-$(CONFIG_MTD_NAND_PASEMI) += pasemi_nand.o
+ obj-$(CONFIG_MTD_NAND_ORION) += orion_nand.o