summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-2.6.36/123-dsa-add-ar7240-built-in-switch-support.patch
diff options
context:
space:
mode:
authorAlexandros C. Couloumbis <alex@ozo.com>2010-10-08 12:10:18 +0000
committerAlexandros C. Couloumbis <alex@ozo.com>2010-10-08 12:10:18 +0000
commit458e8736fc0646f892b77f50e80a24579058bb71 (patch)
treee494f3d2404aa25abfad2345748c0f85dc328678 /target/linux/ar71xx/patches-2.6.36/123-dsa-add-ar7240-built-in-switch-support.patch
parent38e3474542eded63b16cf90a60eb5fa1ec2b9dcf (diff)
downloadmaster-31e0f0ae-458e8736fc0646f892b77f50e80a24579058bb71.tar.gz
master-31e0f0ae-458e8736fc0646f892b77f50e80a24579058bb71.tar.bz2
master-31e0f0ae-458e8736fc0646f892b77f50e80a24579058bb71.zip
linux/ar71xx: add preliminary 2.6.36 kernel support (refresh patches)
SVN-Revision: 23317
Diffstat (limited to 'target/linux/ar71xx/patches-2.6.36/123-dsa-add-ar7240-built-in-switch-support.patch')
-rw-r--r--target/linux/ar71xx/patches-2.6.36/123-dsa-add-ar7240-built-in-switch-support.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-2.6.36/123-dsa-add-ar7240-built-in-switch-support.patch b/target/linux/ar71xx/patches-2.6.36/123-dsa-add-ar7240-built-in-switch-support.patch
new file mode 100644
index 0000000000..50e6e5de27
--- /dev/null
+++ b/target/linux/ar71xx/patches-2.6.36/123-dsa-add-ar7240-built-in-switch-support.patch
@@ -0,0 +1,28 @@
+--- a/net/dsa/Kconfig
++++ b/net/dsa/Kconfig
+@@ -29,6 +29,15 @@ config NET_DSA_TAG_QINQ
+
+
+ # switch drivers
++config NET_DSA_AR7240
++ bool "Atheros AR7240 built-in ethernet switch support"
++ depends on ATHEROS_AR71XX
++ default n
++ select NET_DSA_TAG_QINQ
++ ---help---
++ This enables support for the built-in ethernet switch of the
++ Atheros AR7240 SoC.
++
+ config NET_DSA_MV88E6XXX
+ bool
+ default n
+--- a/net/dsa/Makefile
++++ b/net/dsa/Makefile
+@@ -5,6 +5,7 @@ obj-$(CONFIG_NET_DSA_TAG_QINQ) += tag_qi
+ obj-$(CONFIG_NET_DSA_TAG_TRAILER) += tag_trailer.o
+
+ # switch drivers
++obj-$(CONFIG_NET_DSA_AR7240) += ar7240.o
+ obj-$(CONFIG_NET_DSA_MV88E6XXX) += mv88e6xxx.o
+ obj-$(CONFIG_NET_DSA_MV88E6060) += mv88e6060.o
+ obj-$(CONFIG_NET_DSA_MV88E6063) += mv88e6063.o