summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-2.6.35/101-ksz8041_phy_driver.patch
diff options
context:
space:
mode:
authorAlexandros C. Couloumbis <alex@ozo.com>2010-06-09 10:45:47 +0000
committerAlexandros C. Couloumbis <alex@ozo.com>2010-06-09 10:45:47 +0000
commitd45dc5e820b5589662236143a68928eaec01e83e (patch)
tree64a1434b436174e77545a6b7234612c5f0fdb3da /target/linux/ar71xx/patches-2.6.35/101-ksz8041_phy_driver.patch
parentbef7ceff095e5e648b45b4cf0c73fb7ad588b676 (diff)
downloadmaster-31e0f0ae-d45dc5e820b5589662236143a68928eaec01e83e.tar.gz
master-31e0f0ae-d45dc5e820b5589662236143a68928eaec01e83e.tar.bz2
master-31e0f0ae-d45dc5e820b5589662236143a68928eaec01e83e.zip
ar71xx: add kernel 2.6.35 preliminary support
SVN-Revision: 21734
Diffstat (limited to 'target/linux/ar71xx/patches-2.6.35/101-ksz8041_phy_driver.patch')
-rw-r--r--target/linux/ar71xx/patches-2.6.35/101-ksz8041_phy_driver.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-2.6.35/101-ksz8041_phy_driver.patch b/target/linux/ar71xx/patches-2.6.35/101-ksz8041_phy_driver.patch
new file mode 100644
index 0000000000..5036046108
--- /dev/null
+++ b/target/linux/ar71xx/patches-2.6.35/101-ksz8041_phy_driver.patch
@@ -0,0 +1,24 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -114,6 +114,11 @@ config RTL8306_PHY
+ tristate "Driver for Realtek RTL8306S switches"
+ select SWCONFIG
+
++config MICREL_PHY
++ tristate "Drivers for Micrel/Kendin PHYs"
++ ---help---
++ Currently has a driver for the KSZ8041
++
+ config FIXED_PHY
+ bool "Driver for MDIO Bus/PHY emulation with fixed speed/link PHYs"
+ depends on PHYLIB=y
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -24,6 +24,7 @@ obj-$(CONFIG_RTL8366_SMI) += rtl8366_smi
+ obj-$(CONFIG_RTL8366S_PHY) += rtl8366s.o
+ obj-$(CONFIG_RTL8366RB_PHY) += rtl8366rb.o
+ obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
++obj-$(CONFIG_MICREL) += micrel.o
+ obj-$(CONFIG_FIXED_PHY) += fixed.o
+ obj-$(CONFIG_MDIO_BITBANG) += mdio-bitbang.o
+ obj-$(CONFIG_MDIO_GPIO) += mdio-gpio.o