summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-2.6.34/152-rb4xx-spi-driver.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2010-08-31 20:13:47 +0000
committerGabor Juhos <juhosg@openwrt.org>2010-08-31 20:13:47 +0000
commit47f8fd1dde5d2778cad79313f444a03934d5d0b4 (patch)
tree87d1372d917c4e5903da0a42ecdfed9676f96280 /target/linux/ar71xx/patches-2.6.34/152-rb4xx-spi-driver.patch
parent4ca54a5b3995b80dc814165c244a1d597bfacca1 (diff)
downloadmaster-31e0f0ae-47f8fd1dde5d2778cad79313f444a03934d5d0b4.tar.gz
master-31e0f0ae-47f8fd1dde5d2778cad79313f444a03934d5d0b4.tar.bz2
master-31e0f0ae-47f8fd1dde5d2778cad79313f444a03934d5d0b4.zip
ar71xx: rewrite SPI drivers for the RB4xx boards
* add a new SPI controller driver * add SPI driver for the CPLD chip * convert the NAND driver * enable the mikroSD slot * enable more LEDs SVN-Revision: 22863
Diffstat (limited to 'target/linux/ar71xx/patches-2.6.34/152-rb4xx-spi-driver.patch')
-rw-r--r--target/linux/ar71xx/patches-2.6.34/152-rb4xx-spi-driver.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-2.6.34/152-rb4xx-spi-driver.patch b/target/linux/ar71xx/patches-2.6.34/152-rb4xx-spi-driver.patch
new file mode 100644
index 0000000000..22b803ec67
--- /dev/null
+++ b/target/linux/ar71xx/patches-2.6.34/152-rb4xx-spi-driver.patch
@@ -0,0 +1,25 @@
+--- a/drivers/spi/Kconfig
++++ b/drivers/spi/Kconfig
+@@ -242,6 +242,12 @@ config SPI_PXA2XX
+ The driver can be configured to use any SSP port and additional
+ documentation can be found a Documentation/spi/pxa2xx.
+
++config SPI_RB4XX
++ tristate "Mikrotik RB4XX SPI master"
++ depends on SPI_MASTER && AR71XX_MACH_RB4XX
++ help
++ SPI controller driver for the Mikrotik RB4xx series boards.
++
+ config SPI_S3C24XX
+ tristate "Samsung S3C24XX series SPI"
+ depends on ARCH_S3C2410 && EXPERIMENTAL
+--- a/drivers/spi/Makefile
++++ b/drivers/spi/Makefile
+@@ -47,6 +47,7 @@ obj-$(CONFIG_SPI_SH_SCI) += spi_sh_sci.
+ obj-$(CONFIG_SPI_SH_MSIOF) += spi_sh_msiof.o
+ obj-$(CONFIG_SPI_STMP3XXX) += spi_stmp.o
+ obj-$(CONFIG_SPI_NUC900) += spi_nuc900.o
++obj-$(CONFIG_SPI_RB4XX) += rb4xx_spi.o
+
+ # special build for s3c24xx spi driver with fiq support
+ spi_s3c24xx_hw-y := spi_s3c24xx.o