summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-2.6.33/123-dsa-add-ar7240-built-in-switch-support.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2010-03-08 14:38:43 +0000
committerGabor Juhos <juhosg@openwrt.org>2010-03-08 14:38:43 +0000
commit8eac86e535ca270c196b4fcf1c63570fb94aca15 (patch)
tree55803c5ecc4f36faa90727f7e401576dd6f01758 /target/linux/ar71xx/patches-2.6.33/123-dsa-add-ar7240-built-in-switch-support.patch
parentc859a20e69fbc692026e5a18c166e42d000d7d70 (diff)
downloadmaster-31e0f0ae-8eac86e535ca270c196b4fcf1c63570fb94aca15.tar.gz
master-31e0f0ae-8eac86e535ca270c196b4fcf1c63570fb94aca15.tar.bz2
master-31e0f0ae-8eac86e535ca270c196b4fcf1c63570fb94aca15.zip
ar71xx: enable AR7240 DSA driver on 2.6.33 as well
SVN-Revision: 20059
Diffstat (limited to 'target/linux/ar71xx/patches-2.6.33/123-dsa-add-ar7240-built-in-switch-support.patch')
-rw-r--r--target/linux/ar71xx/patches-2.6.33/123-dsa-add-ar7240-built-in-switch-support.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-2.6.33/123-dsa-add-ar7240-built-in-switch-support.patch b/target/linux/ar71xx/patches-2.6.33/123-dsa-add-ar7240-built-in-switch-support.patch
new file mode 100644
index 0000000000..50e6e5de27
--- /dev/null
+++ b/target/linux/ar71xx/patches-2.6.33/123-dsa-add-ar7240-built-in-switch-support.patch
@@ -0,0 +1,28 @@
+--- a/net/dsa/Kconfig
++++ b/net/dsa/Kconfig
+@@ -29,6 +29,15 @@ config NET_DSA_TAG_QINQ
+
+
+ # switch drivers
++config NET_DSA_AR7240
++ bool "Atheros AR7240 built-in ethernet switch support"
++ depends on ATHEROS_AR71XX
++ default n
++ select NET_DSA_TAG_QINQ
++ ---help---
++ This enables support for the built-in ethernet switch of the
++ Atheros AR7240 SoC.
++
+ config NET_DSA_MV88E6XXX
+ bool
+ default n
+--- a/net/dsa/Makefile
++++ b/net/dsa/Makefile
+@@ -5,6 +5,7 @@ obj-$(CONFIG_NET_DSA_TAG_QINQ) += tag_qi
+ obj-$(CONFIG_NET_DSA_TAG_TRAILER) += tag_trailer.o
+
+ # switch drivers
++obj-$(CONFIG_NET_DSA_AR7240) += ar7240.o
+ obj-$(CONFIG_NET_DSA_MV88E6XXX) += mv88e6xxx.o
+ obj-$(CONFIG_NET_DSA_MV88E6060) += mv88e6060.o
+ obj-$(CONFIG_NET_DSA_MV88E6063) += mv88e6063.o