summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-2.6.32/202-spi_vsc7385_driver.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2009-12-04 20:27:03 +0000
committerGabor Juhos <juhosg@openwrt.org>2009-12-04 20:27:03 +0000
commit9bb13d59d9bc2fbce00c59ff47775aa5f2fb363d (patch)
tree1f278641a045d3f9089594df9b5c792cc5751f1c /target/linux/ar71xx/patches-2.6.32/202-spi_vsc7385_driver.patch
parent3184772820190de3dfca6528dc67002974eb96b5 (diff)
downloadmaster-31e0f0ae-9bb13d59d9bc2fbce00c59ff47775aa5f2fb363d.tar.gz
master-31e0f0ae-9bb13d59d9bc2fbce00c59ff47775aa5f2fb363d.tar.bz2
master-31e0f0ae-9bb13d59d9bc2fbce00c59ff47775aa5f2fb363d.zip
ar71xx: experimental 2.6.32 support
SVN-Revision: 18638
Diffstat (limited to 'target/linux/ar71xx/patches-2.6.32/202-spi_vsc7385_driver.patch')
-rw-r--r--target/linux/ar71xx/patches-2.6.32/202-spi_vsc7385_driver.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-2.6.32/202-spi_vsc7385_driver.patch b/target/linux/ar71xx/patches-2.6.32/202-spi_vsc7385_driver.patch
new file mode 100644
index 0000000000..a4b4595b04
--- /dev/null
+++ b/target/linux/ar71xx/patches-2.6.32/202-spi_vsc7385_driver.patch
@@ -0,0 +1,24 @@
+--- a/drivers/spi/Kconfig
++++ b/drivers/spi/Kconfig
+@@ -296,6 +296,11 @@ config SPI_TLE62X0
+ sysfs interface, with each line presented as a kind of GPIO
+ exposing both switch control and diagnostic feedback.
+
++config SPI_VSC7385
++ tristate "Vitesse VSC7385 ethernet switch driver"
++ help
++ SPI driver for the Vitesse VSC7385 ethernet switch.
++
+ #
+ # Add new SPI protocol masters in alphabetical order above this line
+ #
+--- a/drivers/spi/Makefile
++++ b/drivers/spi/Makefile
+@@ -40,6 +40,7 @@ obj-$(CONFIG_SPI_STMP3XXX) += spi_stmp.
+
+ # SPI protocol drivers (device/link on bus)
+ obj-$(CONFIG_SPI_SPIDEV) += spidev.o
++obj-$(CONFIG_SPI_VSC7385) += spi_vsc7385.o
+ obj-$(CONFIG_SPI_TLE62X0) += tle62x0.o
+ # ... add above this line ...
+