summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-2.6.30
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2009-06-03 19:50:04 +0000
committerGabor Juhos <juhosg@openwrt.org>2009-06-03 19:50:04 +0000
commit0755481965d1e47640458086fc213b0c43f96eb6 (patch)
treea6ea64f156c9259845d8c67a1f46d84232bba5ac /target/linux/ar71xx/patches-2.6.30
parentce93834602989db99ce592228182f4e41b4fadca (diff)
downloadmaster-31e0f0ae-0755481965d1e47640458086fc213b0c43f96eb6.tar.gz
master-31e0f0ae-0755481965d1e47640458086fc213b0c43f96eb6.tar.bz2
master-31e0f0ae-0755481965d1e47640458086fc213b0c43f96eb6.zip
add another SPI controller driver for the earlier AP83 boards
SVN-Revision: 16315
Diffstat (limited to 'target/linux/ar71xx/patches-2.6.30')
-rw-r--r--target/linux/ar71xx/patches-2.6.30/201-ap83_spi_controller.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-2.6.30/201-ap83_spi_controller.patch b/target/linux/ar71xx/patches-2.6.30/201-ap83_spi_controller.patch
new file mode 100644
index 0000000000..a8e889a7bd
--- /dev/null
+++ b/target/linux/ar71xx/patches-2.6.30/201-ap83_spi_controller.patch
@@ -0,0 +1,27 @@
+--- a/drivers/spi/Makefile
++++ b/drivers/spi/Makefile
+@@ -11,6 +11,7 @@ endif
+ obj-$(CONFIG_SPI_MASTER) += spi.o
+
+ # SPI master controller drivers (bus)
++obj-$(CONFIG_SPI_AP83) += ap83_spi.o
+ obj-$(CONFIG_SPI_AR71XX) += ar71xx_spi.o
+ obj-$(CONFIG_SPI_ATMEL) += atmel_spi.o
+ obj-$(CONFIG_SPI_BFIN) += spi_bfin5xx.o
+--- a/drivers/spi/Kconfig
++++ b/drivers/spi/Kconfig
+@@ -53,6 +53,14 @@ if SPI_MASTER
+
+ comment "SPI Master Controller Drivers"
+
++config SPI_AP83
++ tristate "Atheros AP83 specific SPI Controller"
++ depends on SPI_MASTER && AR71XX_MACH_AP83
++ select SPI_BITBANG
++ help
++ This is a specific SPI controller driver for the Atheros AP83
++ reference board.
++
+ config SPI_AR71XX
+ tristate "Atheros AR71xx SPI Controller"
+ depends on SPI_MASTER && ATHEROS_AR71XX