summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-2.6.30/206-nxp-74hc153-gpio-chip-driver.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2010-01-15 12:07:58 +0000
committerGabor Juhos <juhosg@openwrt.org>2010-01-15 12:07:58 +0000
commite92c0c78302971947e0cd77f504ab14dbd3591fe (patch)
treeca1f37364e17836baffbf71033eefb31d4741655 /target/linux/ar71xx/patches-2.6.30/206-nxp-74hc153-gpio-chip-driver.patch
parent7c6b51f9e286204cc9db1d1f5f6b57013b15b123 (diff)
downloadmaster-31e0f0ae-e92c0c78302971947e0cd77f504ab14dbd3591fe.tar.gz
master-31e0f0ae-e92c0c78302971947e0cd77f504ab14dbd3591fe.tar.bz2
master-31e0f0ae-e92c0c78302971947e0cd77f504ab14dbd3591fe.zip
ar71xx: add GPIO driver for the NXP 74HC153 chip
SVN-Revision: 19149
Diffstat (limited to 'target/linux/ar71xx/patches-2.6.30/206-nxp-74hc153-gpio-chip-driver.patch')
-rw-r--r--target/linux/ar71xx/patches-2.6.30/206-nxp-74hc153-gpio-chip-driver.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-2.6.30/206-nxp-74hc153-gpio-chip-driver.patch b/target/linux/ar71xx/patches-2.6.30/206-nxp-74hc153-gpio-chip-driver.patch
new file mode 100644
index 0000000000..0f1613c84d
--- /dev/null
+++ b/target/linux/ar71xx/patches-2.6.30/206-nxp-74hc153-gpio-chip-driver.patch
@@ -0,0 +1,25 @@
+--- a/drivers/gpio/Kconfig
++++ b/drivers/gpio/Kconfig
+@@ -176,4 +176,12 @@ config GPIO_MCP23S08
+ SPI driver for Microchip MCP23S08 I/O expander. This provides
+ a GPIO interface supporting inputs and outputs.
+
++comment "Other GPIO expanders"
++
++config GPIO_NXP_74HC153
++ tristate "NXP 74HC153 Dual 4-input multiplexer"
++ help
++ Platform driver for NXP 74HC153 Dual 4-input Multiplexer. This
++ provides a GPIO interface supporting inputs.
++
+ endif
+--- a/drivers/gpio/Makefile
++++ b/drivers/gpio/Makefile
+@@ -7,6 +7,7 @@ obj-$(CONFIG_GPIOLIB) += gpiolib.o
+ obj-$(CONFIG_GPIO_MAX7301) += max7301.o
+ obj-$(CONFIG_GPIO_MAX732X) += max732x.o
+ obj-$(CONFIG_GPIO_MCP23S08) += mcp23s08.o
++obj-$(CONFIG_GPIO_NXP_74HC153) += nxp_74hc153.o
+ obj-$(CONFIG_GPIO_PCA953X) += pca953x.o
+ obj-$(CONFIG_GPIO_PCF857X) += pcf857x.o
+ obj-$(CONFIG_GPIO_TWL4030) += twl4030-gpio.o