summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-2.6.30/006-ar71xx_wdt_driver.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2009-05-02 19:59:19 +0000
committerGabor Juhos <juhosg@openwrt.org>2009-05-02 19:59:19 +0000
commit1de7321026a71ec8249e2e3df7a7c5c8cdf65f9f (patch)
treef5ddb0452dffc986234401fbfa23d7a62377a61c /target/linux/ar71xx/patches-2.6.30/006-ar71xx_wdt_driver.patch
parent1a24fcd9ecdeb5256c80ccde1530943d15b7a9a6 (diff)
downloadmaster-31e0f0ae-1de7321026a71ec8249e2e3df7a7c5c8cdf65f9f.tar.gz
master-31e0f0ae-1de7321026a71ec8249e2e3df7a7c5c8cdf65f9f.tar.bz2
master-31e0f0ae-1de7321026a71ec8249e2e3df7a7c5c8cdf65f9f.zip
add experimental support for 2.6.30
SVN-Revision: 15561
Diffstat (limited to 'target/linux/ar71xx/patches-2.6.30/006-ar71xx_wdt_driver.patch')
-rw-r--r--target/linux/ar71xx/patches-2.6.30/006-ar71xx_wdt_driver.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-2.6.30/006-ar71xx_wdt_driver.patch b/target/linux/ar71xx/patches-2.6.30/006-ar71xx_wdt_driver.patch
new file mode 100644
index 0000000000..2c3b68ff54
--- /dev/null
+++ b/target/linux/ar71xx/patches-2.6.30/006-ar71xx_wdt_driver.patch
@@ -0,0 +1,26 @@
+--- a/drivers/watchdog/Kconfig
++++ b/drivers/watchdog/Kconfig
+@@ -764,6 +764,13 @@ config TXX9_WDT
+ help
+ Hardware driver for the built-in watchdog timer on TXx9 MIPS SoCs.
+
++config AR71XX_WDT
++ tristate "Atheros AR71xx Watchdog Timer"
++ depends on ATHEROS_AR71XX
++ help
++ Hardware driver for the built-in watchdog timer on the Atheros
++ AR71xx SoCs.
++
+ # PARISC Architecture
+
+ # POWERPC Architecture
+--- a/drivers/watchdog/Makefile
++++ b/drivers/watchdog/Makefile
+@@ -105,6 +105,7 @@ obj-$(CONFIG_WDT_RM9K_GPI) += rm9k_wdt.o
+ obj-$(CONFIG_SIBYTE_WDOG) += sb_wdog.o
+ obj-$(CONFIG_AR7_WDT) += ar7_wdt.o
+ obj-$(CONFIG_TXX9_WDT) += txx9wdt.o
++obj-$(CONFIG_AR71XX_WDT) += ar71xx_wdt.o
+
+ # PARISC Architecture
+