summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-2.6.29
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2009-04-23 20:14:48 +0000
committerGabor Juhos <juhosg@openwrt.org>2009-04-23 20:14:48 +0000
commit8b82de7aa00be10315a8d1c514e3026ab590ce88 (patch)
tree643cfcebbb3de70623160f3bdea175c18676f3cd /target/linux/ar71xx/patches-2.6.29
parentb60fc68fa8587e17dc555b9163a86a3dbf93c922 (diff)
downloadmaster-31e0f0ae-8b82de7aa00be10315a8d1c514e3026ab590ce88.tar.gz
master-31e0f0ae-8b82de7aa00be10315a8d1c514e3026ab590ce88.tar.bz2
master-31e0f0ae-8b82de7aa00be10315a8d1c514e3026ab590ce88.zip
add initial support for 2.6.29
SVN-Revision: 15357
Diffstat (limited to 'target/linux/ar71xx/patches-2.6.29')
-rw-r--r--target/linux/ar71xx/patches-2.6.29/001-ar71xx_core.patch50
-rw-r--r--target/linux/ar71xx/patches-2.6.29/002-ar71xx_pci.patch10
-rw-r--r--target/linux/ar71xx/patches-2.6.29/003-ar71xx_usb_host.patch58
-rw-r--r--target/linux/ar71xx/patches-2.6.29/004-ar71xx_spi_controller.patch26
-rw-r--r--target/linux/ar71xx/patches-2.6.29/005-ar71xx_mac_driver.patch21
-rw-r--r--target/linux/ar71xx/patches-2.6.29/006-ar71xx_wdt_driver.patch26
-rw-r--r--target/linux/ar71xx/patches-2.6.29/100-mtd_m25p80_add_pm25lv_flash_support.patch13
-rw-r--r--target/linux/ar71xx/patches-2.6.29/101-ksz8041_phy_driver.patch24
-rw-r--r--target/linux/ar71xx/patches-2.6.29/102-mtd_m25p80_add_myloader_parser.patch22
-rw-r--r--target/linux/ar71xx/patches-2.6.29/103-mtd_m25p80_add_en25p32_support.patch12
-rw-r--r--target/linux/ar71xx/patches-2.6.29/104-mtd_m25p80_add_redboot_parser.patch12
-rw-r--r--target/linux/ar71xx/patches-2.6.29/105-mtd_m25p80_add_mx25lxxx_support.patch14
-rw-r--r--target/linux/ar71xx/patches-2.6.29/106-mtd_m25p80_add_xxxs33b_support.patch14
-rw-r--r--target/linux/ar71xx/patches-2.6.29/110-usb-ehci-add-war-for-synopsys-hc-bug.patch22
-rw-r--r--target/linux/ar71xx/patches-2.6.29/140-redboot_partition_scan.patch54
-rw-r--r--target/linux/ar71xx/patches-2.6.29/200-rb4xx_nand_driver.patch21
-rw-r--r--target/linux/ar71xx/patches-2.6.29/300-mips_fw_myloader.patch22
-rw-r--r--target/linux/ar71xx/patches-2.6.29/301-enable_prom_emulator.patch10
-rw-r--r--target/linux/ar71xx/patches-2.6.29/901-get_c0_compare_irq_function.patch29
-rw-r--r--target/linux/ar71xx/patches-2.6.29/902-mips_clocksource_init_war.patch56
20 files changed, 516 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-2.6.29/001-ar71xx_core.patch b/target/linux/ar71xx/patches-2.6.29/001-ar71xx_core.patch
new file mode 100644
index 0000000000..da6d2e79eb
--- /dev/null
+++ b/target/linux/ar71xx/patches-2.6.29/001-ar71xx_core.patch
@@ -0,0 +1,50 @@
+--- a/arch/mips/Makefile
++++ b/arch/mips/Makefile
+@@ -602,6 +602,13 @@ else
+ load-$(CONFIG_CPU_CAVIUM_OCTEON) += 0xffffffff81100000
+ endif
+
++#
++# Atheros AR71xx
++#
++core-$(CONFIG_ATHEROS_AR71XX) += arch/mips/ar71xx/
++cflags-$(CONFIG_ATHEROS_AR71XX) += -I$(srctree)/arch/mips/include/asm/mach-ar71xx
++load-$(CONFIG_ATHEROS_AR71XX) += 0xffffffff80060000
++
+ # temporary until string.h is fixed
+ cflags-y += -ffreestanding
+
+--- a/arch/mips/Kconfig
++++ b/arch/mips/Kconfig
+@@ -22,6 +22,23 @@ choice
+ config MACH_ALCHEMY
+ bool "Alchemy processor based machines"
+
++config ATHEROS_AR71XX
++ bool "Atheros AR71xx based boards"
++ select CEVT_R4K
++ select CSRC_R4K
++ select DMA_NONCOHERENT
++ select HW_HAS_PCI
++ select IRQ_CPU
++ select ARCH_REQUIRE_GPIOLIB
++ select SYS_HAS_CPU_MIPS32_R1
++ select SYS_HAS_CPU_MIPS32_R2
++ select SYS_SUPPORTS_32BIT_KERNEL
++ select SYS_SUPPORTS_BIG_ENDIAN
++ select SYS_HAS_EARLY_PRINTK
++ select MIPS_MACHINE
++ help
++ Support for Atheros AR71xx based boards.
++
+ config BASLER_EXCITE
+ bool "Basler eXcite smart camera"
+ select CEVT_R4K
+@@ -640,6 +657,7 @@ config CAVIUM_OCTEON_REFERENCE_BOARD
+ endchoice
+
+ source "arch/mips/alchemy/Kconfig"
++source "arch/mips/ar71xx/Kconfig"
+ source "arch/mips/basler/excite/Kconfig"
+ source "arch/mips/jazz/Kconfig"
+ source "arch/mips/lasat/Kconfig"
diff --git a/target/linux/ar71xx/patches-2.6.29/002-ar71xx_pci.patch b/target/linux/ar71xx/patches-2.6.29/002-ar71xx_pci.patch
new file mode 100644
index 0000000000..8e022afa97
--- /dev/null
+++ b/target/linux/ar71xx/patches-2.6.29/002-ar71xx_pci.patch
@@ -0,0 +1,10 @@
+--- a/arch/mips/pci/Makefile
++++ b/arch/mips/pci/Makefile
+@@ -16,6 +16,7 @@ obj-$(CONFIG_PCI_VR41XX) += ops-vr41xx.o
+ obj-$(CONFIG_NEC_MARKEINS) += ops-emma2rh.o pci-emma2rh.o fixup-emma2rh.o
+ obj-$(CONFIG_PCI_TX4927) += ops-tx4927.o
+ obj-$(CONFIG_BCM47XX) += pci-bcm47xx.o
++obj-$(CONFIG_ATHEROS_AR71XX) += pci-ar71xx.o
+
+ #
+ # These are still pretty much in the old state, watch, go blind.
diff --git a/target/linux/ar71xx/patches-2.6.29/003-ar71xx_usb_host.patch b/target/linux/ar71xx/patches-2.6.29/003-ar71xx_usb_host.patch
new file mode 100644
index 0000000000..f5247efc26
--- /dev/null
+++ b/target/linux/ar71xx/patches-2.6.29/003-ar71xx_usb_host.patch
@@ -0,0 +1,58 @@
+--- a/drivers/usb/host/Kconfig
++++ b/drivers/usb/host/Kconfig
+@@ -81,6 +81,13 @@ config USB_EHCI_BIG_ENDIAN_DESC
+ depends on USB_EHCI_HCD && (440EPX || ARCH_IXP4XX)
+ default y
+
++config USB_EHCI_AR71XX
++ bool "USB EHCI support for AR71xx"
++ depends on USB_EHCI_HCD && ATHEROS_AR71XX
++ default y
++ help
++ Support for Atheros AR71xx built-in EHCI controller
++
+ config USB_EHCI_FSL
+ bool "Support for Freescale on-chip EHCI USB controller"
+ depends on USB_EHCI_HCD && FSL_SOC
+@@ -154,6 +161,13 @@ config USB_OHCI_HCD
+ To compile this driver as a module, choose M here: the
+ module will be called ohci-hcd.
+
++config USB_OHCI_AR71XX
++ bool "USB OHCI support for Atheros AR71xx"
++ depends on USB_OHCI_HCD && ATHEROS_AR71XX
++ default y
++ help
++ Support for Atheros AR71xx built-in OHCI controller
++
+ config USB_OHCI_HCD_PPC_SOC
+ bool "OHCI support for on-chip PPC USB controller"
+ depends on USB_OHCI_HCD && (STB03xxx || PPC_MPC52xx)
+--- a/drivers/usb/host/ehci-hcd.c
++++ b/drivers/usb/host/ehci-hcd.c
+@@ -1036,6 +1036,11 @@ MODULE_LICENSE ("GPL");
+ #define PLATFORM_DRIVER ixp4xx_ehci_driver
+ #endif
+
++#ifdef CONFIG_USB_EHCI_AR71XX
++#include "ehci-ar71xx.c"
++#define PLATFORM_DRIVER ehci_ar71xx_driver
++#endif
++
+ #if !defined(PCI_DRIVER) && !defined(PLATFORM_DRIVER) && \
+ !defined(PS3_SYSTEM_BUS_DRIVER) && !defined(OF_PLATFORM_DRIVER)
+ #error "missing bus glue for ehci-hcd"
+--- a/drivers/usb/host/ohci-hcd.c
++++ b/drivers/usb/host/ohci-hcd.c
+@@ -1080,6 +1080,11 @@ MODULE_LICENSE ("GPL");
+ #define TMIO_OHCI_DRIVER ohci_hcd_tmio_driver
+ #endif
+
++#ifdef CONFIG_USB_OHCI_AR71XX
++#include "ohci-ar71xx.c"
++#define PLATFORM_DRIVER ohci_hcd_ar71xx_driver
++#endif
++
+ #if !defined(PCI_DRIVER) && \
+ !defined(PLATFORM_DRIVER) && \
+ !defined(OF_PLATFORM_DRIVER) && \
diff --git a/target/linux/ar71xx/patches-2.6.29/004-ar71xx_spi_controller.patch b/target/linux/ar71xx/patches-2.6.29/004-ar71xx_spi_controller.patch
new file mode 100644
index 0000000000..9c196e077e
--- /dev/null
+++ b/target/linux/ar71xx/patches-2.6.29/004-ar71xx_spi_controller.patch
@@ -0,0 +1,26 @@
+--- a/drivers/spi/Kconfig
++++ b/drivers/spi/Kconfig
+@@ -53,6 +53,13 @@ if SPI_MASTER
+
+ comment "SPI Master Controller Drivers"
+
++config SPI_AR71XX
++ tristate "Atheros AR71xx SPI Controller"
++ depends on SPI_MASTER && ATHEROS_AR71XX
++ select SPI_BITBANG
++ help
++ This is the SPI contoller driver for Atheros AR71xx.
++
+ config SPI_ATMEL
+ tristate "Atmel SPI Controller"
+ depends on (ARCH_AT91 || AVR32)
+--- a/drivers/spi/Makefile
++++ b/drivers/spi/Makefile
+@@ -11,6 +11,7 @@ endif
+ obj-$(CONFIG_SPI_MASTER) += spi.o
+
+ # SPI master controller drivers (bus)
++obj-$(CONFIG_SPI_AR71XX) += ar71xx_spi.o
+ obj-$(CONFIG_SPI_ATMEL) += atmel_spi.o
+ obj-$(CONFIG_SPI_BFIN) += spi_bfin5xx.o
+ obj-$(CONFIG_SPI_BITBANG) += spi_bitbang.o
diff --git a/target/linux/ar71xx/patches-2.6.29/005-ar71xx_mac_driver.patch b/target/linux/ar71xx/patches-2.6.29/005-ar71xx_mac_driver.patch
new file mode 100644
index 0000000000..7bd72c1d55
--- /dev/null
+++ b/target/linux/ar71xx/patches-2.6.29/005-ar71xx_mac_driver.patch
@@ -0,0 +1,21 @@
+--- a/drivers/net/Kconfig
++++ b/drivers/net/Kconfig
+@@ -2068,6 +2068,8 @@ config ACENIC_OMIT_TIGON_I
+
+ The safe and default value for this is N.
+
++source drivers/net/ag71xx/Kconfig
++
+ config DL2K
+ tristate "DL2000/TC902x-based Gigabit Ethernet support"
+ depends on PCI
+--- a/drivers/net/Makefile
++++ b/drivers/net/Makefile
+@@ -2,6 +2,7 @@
+ # Makefile for the Linux network (ethercard) device drivers.
+ #
+
++obj-$(CONFIG_AG71XX) += ag71xx/
+ obj-$(CONFIG_E1000) += e1000/
+ obj-$(CONFIG_E1000E) += e1000e/
+ obj-$(CONFIG_IBM_NEW_EMAC) += ibm_newemac/
diff --git a/target/linux/ar71xx/patches-2.6.29/006-ar71xx_wdt_driver.patch b/target/linux/ar71xx/patches-2.6.29/006-ar71xx_wdt_driver.patch
new file mode 100644
index 0000000000..60f6a6407c
--- /dev/null
+++ b/target/linux/ar71xx/patches-2.6.29/006-ar71xx_wdt_driver.patch
@@ -0,0 +1,26 @@
+--- a/drivers/watchdog/Kconfig
++++ b/drivers/watchdog/Kconfig
+@@ -766,6 +766,13 @@ config TXX9_WDT
+ help
+ Hardware driver for the built-in watchdog timer on TXx9 MIPS SoCs.
+
++config AR71XX_WDT
++ tristate "Atheros AR71xx Watchdog Timer"
++ depends on ATHEROS_AR71XX
++ help
++ Hardware driver for the built-in watchdog timer on the Atheros
++ AR71xx SoCs.
++
+ # PARISC Architecture
+
+ # POWERPC Architecture
+--- a/drivers/watchdog/Makefile
++++ b/drivers/watchdog/Makefile
+@@ -107,6 +107,7 @@ obj-$(CONFIG_WDT_RM9K_GPI) += rm9k_wdt.o
+ obj-$(CONFIG_SIBYTE_WDOG) += sb_wdog.o
+ obj-$(CONFIG_AR7_WDT) += ar7_wdt.o
+ obj-$(CONFIG_TXX9_WDT) += txx9wdt.o
++obj-$(CONFIG_AR71XX_WDT) += ar71xx_wdt.o
+
+ # PARISC Architecture
+
diff --git a/target/linux/ar71xx/patches-2.6.29/100-mtd_m25p80_add_pm25lv_flash_support.patch b/target/linux/ar71xx/patches-2.6.29/100-mtd_m25p80_add_pm25lv_flash_support.patch
new file mode 100644
index 0000000000..07a5b0b71b
--- /dev/null
+++ b/target/linux/ar71xx/patches-2.6.29/100-mtd_m25p80_add_pm25lv_flash_support.patch
@@ -0,0 +1,13 @@
+--- a/drivers/mtd/devices/m25p80.c
++++ b/drivers/mtd/devices/m25p80.c
+@@ -504,6 +504,10 @@ static struct flash_info __devinitdata m
+ { "at26df161a", 0x1f4601, 0, 64 * 1024, 32, SECT_4K, },
+ { "at26df321", 0x1f4701, 0, 64 * 1024, 64, SECT_4K, },
+
++ /* PMC -- pm25x "blocks" are 32K, sectors are 4K */
++ { "pm25lv512", 0, 32 * 1024, 2, SECT_4K },
++ { "pm25lv010", 0, 32 * 1024, 4, SECT_4K },
++
+ /* Spansion -- single (large) sector size only, at least
+ * for the chips listed here (without boot sectors).
+ */
diff --git a/target/linux/ar71xx/patches-2.6.29/101-ksz8041_phy_driver.patch b/target/linux/ar71xx/patches-2.6.29/101-ksz8041_phy_driver.patch
new file mode 100644
index 0000000000..eec879660e
--- /dev/null
+++ b/target/linux/ar71xx/patches-2.6.29/101-ksz8041_phy_driver.patch
@@ -0,0 +1,24 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -96,6 +96,11 @@ config ADM6996_PHY
+ config MVSWITCH_PHY
+ tristate "Driver for Marvell 88E6060 switches"
+
++config MICREL_PHY
++ tristate "Drivers for Micrel/Kendin PHYs"
++ ---help---
++ Currently has a driver for the KSZ8041
++
+ config FIXED_PHY
+ bool "Driver for MDIO Bus/PHY emulation with fixed speed/link PHYs"
+ depends on PHYLIB=y
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -17,6 +17,7 @@ obj-$(CONFIG_ADM6996_PHY) += adm6996.o
+ obj-$(CONFIG_MVSWITCH_PHY) += mvswitch.o
+ obj-$(CONFIG_REALTEK_PHY) += realtek.o
+ obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
++obj-$(CONFIG_MICREL) += micrel.o
+ obj-$(CONFIG_FIXED_PHY) += fixed.o
+ obj-$(CONFIG_MDIO_BITBANG) += mdio-bitbang.o
+ obj-$(CONFIG_MDIO_GPIO) += mdio-gpio.o
diff --git a/target/linux/ar71xx/patches-2.6.29/102-mtd_m25p80_add_myloader_parser.patch b/target/linux/ar71xx/patches-2.6.29/102-mtd_m25p80_add_myloader_parser.patch
new file mode 100644
index 0000000000..ecafebad86
--- /dev/null
+++ b/target/linux/ar71xx/patches-2.6.29/102-mtd_m25p80_add_myloader_parser.patch
@@ -0,0 +1,22 @@
+--- a/drivers/mtd/devices/m25p80.c
++++ b/drivers/mtd/devices/m25p80.c
+@@ -712,12 +712,17 @@ static int __devinit m25p_probe(struct s
+ struct mtd_partition *parts = NULL;
+ int nr_parts = 0;
+
++ static const char *part_probes[] = {
+ #ifdef CONFIG_MTD_CMDLINE_PARTS
+- static const char *part_probes[] = { "cmdlinepart", NULL, };
++ "cmdlinepart",
++#endif
++#ifdef CONFIG_MTD_MYLOADER_PARTS
++ "MyLoader",
++#endif
++ NULL, };
+
+ nr_parts = parse_mtd_partitions(&flash->mtd,
+ part_probes, &parts, 0);
+-#endif
+
+ if (nr_parts <= 0 && data && data->parts) {
+ parts = data->parts;
diff --git a/target/linux/ar71xx/patches-2.6.29/103-mtd_m25p80_add_en25p32_support.patch b/target/linux/ar71xx/patches-2.6.29/103-mtd_m25p80_add_en25p32_support.patch
new file mode 100644
index 0000000000..0ee04158e1
--- /dev/null
+++ b/target/linux/ar71xx/patches-2.6.29/103-mtd_m25p80_add_en25p32_support.patch
@@ -0,0 +1,12 @@
+--- a/drivers/mtd/devices/m25p80.c
++++ b/drivers/mtd/devices/m25p80.c
+@@ -504,6 +504,9 @@ static struct flash_info __devinitdata m
+ { "at26df161a", 0x1f4601, 0, 64 * 1024, 32, SECT_4K, },
+ { "at26df321", 0x1f4701, 0, 64 * 1024, 64, SECT_4K, },
+
++ /* EON -- en25px */
++ { "en25p32", 0x1c2016, 0, 64 * 1024, 64, },
++
+ /* PMC -- pm25x "blocks" are 32K, sectors are 4K */
+ { "pm25lv512", 0, 32 * 1024, 2, SECT_4K },
+ { "pm25lv010", 0, 32 * 1024, 4, SECT_4K },
diff --git a/target/linux/ar71xx/patches-2.6.29/104-mtd_m25p80_add_redboot_parser.patch b/target/linux/ar71xx/patches-2.6.29/104-mtd_m25p80_add_redboot_parser.patch
new file mode 100644
index 0000000000..462ae68791
--- /dev/null
+++ b/target/linux/ar71xx/patches-2.6.29/104-mtd_m25p80_add_redboot_parser.patch
@@ -0,0 +1,12 @@
+--- a/drivers/mtd/devices/m25p80.c
++++ b/drivers/mtd/devices/m25p80.c
+@@ -722,6 +722,9 @@ static int __devinit m25p_probe(struct s
+ #ifdef CONFIG_MTD_MYLOADER_PARTS
+ "MyLoader",
+ #endif
++#ifdef CONFIG_MTD_REDBOOT_PARTS
++ "RedBoot",
++#endif
+ NULL, };
+
+ nr_parts = parse_mtd_partitions(&flash->mtd,
diff --git a/target/linux/ar71xx/patches-2.6.29/105-mtd_m25p80_add_mx25lxxx_support.patch b/target/linux/ar71xx/patches-2.6.29/105-mtd_m25p80_add_mx25lxxx_support.patch
new file mode 100644
index 0000000000..9456ac4314
--- /dev/null
+++ b/target/linux/ar71xx/patches-2.6.29/105-mtd_m25p80_add_mx25lxxx_support.patch
@@ -0,0 +1,14 @@
+--- a/drivers/mtd/devices/m25p80.c
++++ b/drivers/mtd/devices/m25p80.c
+@@ -507,6 +507,11 @@ static struct flash_info __devinitdata m
+ /* EON -- en25px */
+ { "en25p32", 0x1c2016, 0, 64 * 1024, 64, },
+
++ /* Macronix -- mx25lxxx */
++ { "mx25l32", 0xc22016, 0, 64 * 1024, 64, },
++ { "mx25l64", 0xc22017, 0, 64 * 1024, 128, },
++ { "mx25l128", 0xc22018, 0, 64 * 1024, 256, },
++
+ /* PMC -- pm25x "blocks" are 32K, sectors are 4K */
+ { "pm25lv512", 0, 32 * 1024, 2, SECT_4K },
+ { "pm25lv010", 0, 32 * 1024, 4, SECT_4K },
diff --git a/target/linux/ar71xx/patches-2.6.29/106-mtd_m25p80_add_xxxs33b_support.patch b/target/linux/ar71xx/patches-2.6.29/106-mtd_m25p80_add_xxxs33b_support.patch
new file mode 100644
index 0000000000..e4e01637d6
--- /dev/null
+++ b/target/linux/ar71xx/patches-2.6.29/106-mtd_m25p80_add_xxxs33b_support.patch
@@ -0,0 +1,14 @@
+--- a/drivers/mtd/devices/m25p80.c
++++ b/drivers/mtd/devices/m25p80.c
+@@ -512,6 +512,11 @@ static struct flash_info __devinitdata m
+ { "mx25l64", 0xc22017, 0, 64 * 1024, 128, },
+ { "mx25l128", 0xc22018, 0, 64 * 1024, 256, },
+
++ /* Numonyx -- xxxs33b */
++ { "160s33b", 0x898911, 0, 64 * 1024, 64, },
++ { "320s33b", 0x898912, 0, 64 * 1024, 128, },
++ { "640s33b", 0x898913, 0, 64 * 1024, 256, },
++
+ /* PMC -- pm25x "blocks" are 32K, sectors are 4K */
+ { "pm25lv512", 0, 32 * 1024, 2, SECT_4K },
+ { "pm25lv010", 0, 32 * 1024, 4, SECT_4K },
diff --git a/target/linux/ar71xx/patches-2.6.29/110-usb-ehci-add-war-for-synopsys-hc-bug.patch b/target/linux/ar71xx/patches-2.6.29/110-usb-ehci-add-war-for-synopsys-hc-bug.patch
new file mode 100644
index 0000000000..ff4c594a02
--- /dev/null
+++ b/target/linux/ar71xx/patches-2.6.29/110-usb-ehci-add-war-for-synopsys-hc-bug.patch
@@ -0,0 +1,22 @@
+--- a/drivers/usb/host/ehci-q.c
++++ b/drivers/usb/host/ehci-q.c
+@@ -1082,6 +1082,9 @@ static void end_unlink_async (struct ehc
+ ehci->reclaim = NULL;
+ start_unlink_async (ehci, next);
+ }
++
++ if (ehci->has_synopsys_hc_bug)
++ writel((u32)ehci->async->qh_dma, &ehci->regs->async_next);
+ }
+
+ /* makes sure the async qh will become idle */
+--- a/drivers/usb/host/ehci.h
++++ b/drivers/usb/host/ehci.h
+@@ -125,6 +125,7 @@ struct ehci_hcd { /* one per controlle
+ unsigned big_endian_mmio:1;
+ unsigned big_endian_desc:1;
+ unsigned has_amcc_usb23:1;
++ unsigned has_synopsys_hc_bug:1; /* Synopsys HC */
+
+ /* required for usb32 quirk */
+ #define OHCI_CTRL_HCFS (3 << 6)
diff --git a/target/linux/ar71xx/patches-2.6.29/140-redboot_partition_scan.patch b/target/linux/ar71xx/patches-2.6.29/140-redboot_partition_scan.patch
new file mode 100644
index 0000000000..289d4eb990
--- /dev/null
+++ b/target/linux/ar71xx/patches-2.6.29/140-redboot_partition_scan.patch
@@ -0,0 +1,54 @@
+--- a/drivers/mtd/redboot.c
++++ b/drivers/mtd/redboot.c
+@@ -60,31 +60,32 @@ static int parse_redboot_partitions(stru
+ static char nullstring[] = "unallocated";
+ #endif
+
++ buf = vmalloc(master->erasesize);
++ if (!buf)
++ return -ENOMEM;
++
++ restart:
+ if ( directory < 0 ) {
+ offset = master->size + directory * master->erasesize;
+- while (master->block_isbad &&
++ while (master->block_isbad &&
+ master->block_isbad(master, offset)) {
+ if (!offset) {
+ nogood:
+ printk(KERN_NOTICE "Failed to find a non-bad block to check for RedBoot partition table\n");
++ vfree(buf);
+ return -EIO;
+ }
+ offset -= master->erasesize;
+ }
+ } else {
+ offset = directory * master->erasesize;
+- while (master->block_isbad &&
++ while (master->block_isbad &&
+ master->block_isbad(master, offset)) {
+ offset += master->erasesize;
+ if (offset == master->size)
+ goto nogood;
+ }
+ }
+- buf = vmalloc(master->erasesize);
+-
+- if (!buf)
+- return -ENOMEM;
+-
+ printk(KERN_NOTICE "Searching for RedBoot partition table in %s at offset 0x%lx\n",
+ master->name, offset);
+
+@@ -156,6 +157,11 @@ static int parse_redboot_partitions(stru
+ }
+ if (i == numslots) {
+ /* Didn't find it */
++ if (offset + master->erasesize < master->size) {
++ /* not at the end of the flash yet, maybe next block :) */
++ directory++;
++ goto restart;
++ }
+ printk(KERN_NOTICE "No RedBoot partition table detected in %s\n",
+ master->name);
+ ret = 0;
diff --git a/target/linux/ar71xx/patches-2.6.29/200-rb4xx_nand_driver.patch b/target/linux/ar71xx/patches-2.6.29/200-rb4xx_nand_driver.patch
new file mode 100644
index 0000000000..06d5ea49ef
--- /dev/null
+++ b/target/linux/ar71xx/patches-2.6.29/200-rb4xx_nand_driver.patch
@@ -0,0 +1,21 @@
+--- a/drivers/mtd/nand/Kconfig
++++ b/drivers/mtd/nand/Kconfig
+@@ -427,4 +427,8 @@ config MTD_NAND_SH_FLCTL
+ Several Renesas SuperH CPU has FLCTL. This option enables support
+ for NAND Flash using FLCTL. This driver support SH7723.
+
++config MTD_NAND_RB4XX
++ tristate "NAND flash driver for RouterBoard 4xx series"
++ depends on MTD_NAND && ATHEROS_AR71XX
++
+ endif # MTD_NAND
+--- a/drivers/mtd/nand/Makefile
++++ b/drivers/mtd/nand/Makefile
+@@ -29,6 +29,7 @@ obj-$(CONFIG_MTD_NAND_BASLER_EXCITE) +=
+ obj-$(CONFIG_MTD_NAND_PXA3xx) += pxa3xx_nand.o
+ obj-$(CONFIG_MTD_NAND_TMIO) += tmio_nand.o
+ obj-$(CONFIG_MTD_NAND_PLATFORM) += plat_nand.o
++obj-$(CONFIG_MTD_NAND_RB4XX) += rb4xx_nand.o
+ obj-$(CONFIG_MTD_ALAUDA) += alauda.o
+ obj-$(CONFIG_MTD_NAND_PASEMI) += pasemi_nand.o
+ obj-$(CONFIG_MTD_NAND_ORION) += orion_nand.o
diff --git a/target/linux/ar71xx/patches-2.6.29/300-mips_fw_myloader.patch b/target/linux/ar71xx/patches-2.6.29/300-mips_fw_myloader.patch
new file mode 100644
index 0000000000..db0c4b21d2
--- /dev/null
+++ b/target/linux/ar71xx/patches-2.6.29/300-mips_fw_myloader.patch
@@ -0,0 +1,22 @@
+--- a/arch/mips/Makefile
++++ b/arch/mips/Makefile
+@@ -164,6 +164,7 @@ endif
+ #
+ libs-$(CONFIG_ARC) += arch/mips/fw/arc/
+ libs-$(CONFIG_CFE) += arch/mips/fw/cfe/
++libs-$(CONFIG_MYLOADER) += arch/mips/fw/myloader/
+ libs-$(CONFIG_SNIPROM) += arch/mips/fw/sni/
+ libs-y += arch/mips/fw/lib/
+ libs-$(CONFIG_SIBYTE_CFE) += arch/mips/sibyte/cfe/
+--- a/arch/mips/Kconfig
++++ b/arch/mips/Kconfig
+@@ -825,6 +825,9 @@ config MIPS_NILE4
+ config MIPS_DISABLE_OBSOLETE_IDE
+ bool
+
++config MYLOADER
++ bool
++
+ config SYNC_R4K
+ bool
+
diff --git a/target/linux/ar71xx/patches-2.6.29/301-enable_prom_emulator.patch b/target/linux/ar71xx/patches-2.6.29/301-enable_prom_emulator.patch
new file mode 100644
index 0000000000..5ed804666c
--- /dev/null
+++ b/target/linux/ar71xx/patches-2.6.29/301-enable_prom_emulator.patch
@@ -0,0 +1,10 @@
+--- a/arch/mips/Kconfig
++++ b/arch/mips/Kconfig
+@@ -36,6 +36,7 @@ config ATHEROS_AR71XX
+ select SYS_SUPPORTS_BIG_ENDIAN
+ select SYS_HAS_EARLY_PRINTK
+ select MIPS_MACHINE
++ select PROM_EMU
+ help
+ Support for Atheros AR71xx based boards.
+
diff --git a/target/linux/ar71xx/patches-2.6.29/901-get_c0_compare_irq_function.patch b/target/linux/ar71xx/patches-2.6.29/901-get_c0_compare_irq_function.patch
new file mode 100644
index 0000000000..ffc06ed7ed
--- /dev/null
+++ b/target/linux/ar71xx/patches-2.6.29/901-get_c0_compare_irq_function.patch
@@ -0,0 +1,29 @@
+--- a/arch/mips/kernel/traps.c
++++ b/arch/mips/kernel/traps.c
+@@ -48,6 +48,7 @@
+ #include <asm/types.h>
+ #include <asm/stacktrace.h>
+ #include <asm/irq.h>
++#include <asm/time.h>
+
+ extern void check_wait(void);
+ extern asmlinkage void r4k_wait(void);
+@@ -1541,6 +1542,8 @@ void __cpuinit per_cpu_trap_init(void)
+ */
+ if (cpu_has_mips_r2) {
+ cp0_compare_irq = (read_c0_intctl() >> 29) & 7;
++ if (get_c0_compare_irq)
++ cp0_compare_irq = get_c0_compare_irq();
+ cp0_perfcount_irq = (read_c0_intctl() >> 26) & 7;
+ if (cp0_perfcount_irq == cp0_compare_irq)
+ cp0_perfcount_irq = -1;
+--- a/arch/mips/include/asm/time.h
++++ b/arch/mips/include/asm/time.h
+@@ -52,6 +52,7 @@ extern int (*perf_irq)(void);
+ */
+ #ifdef CONFIG_CEVT_R4K_LIB
+ extern unsigned int __weak get_c0_compare_int(void);
++extern unsigned int __weak get_c0_compare_irq(void);
+ extern int r4k_clockevent_init(void);
+ #endif
+
diff --git a/target/linux/ar71xx/patches-2.6.29/902-mips_clocksource_init_war.patch b/target/linux/ar71xx/patches-2.6.29/902-mips_clocksource_init_war.patch
new file mode 100644
index 0000000000..03a66ff133
--- /dev/null
+++ b/target/linux/ar71xx/patches-2.6.29/902-mips_clocksource_init_war.patch
@@ -0,0 +1,56 @@
+--- a/arch/mips/kernel/cevt-r4k.c
++++ b/arch/mips/kernel/cevt-r4k.c
+@@ -15,6 +15,22 @@
+ #include <asm/cevt-r4k.h>
+
+ /*
++ * Compare interrupt can be routed and latched outside the core,
++ * so a single execution hazard barrier may not be enough to give
++ * it time to clear as seen in the Cause register. 4 time the
++ * pipeline depth seems reasonably conservative, and empirically
++ * works better in configurations with high CPU/bus clock ratios.
++ */
++
++#define compare_change_hazard() \
++ do { \
++ irq_disable_hazard(); \
++ irq_disable_hazard(); \
++ irq_disable_hazard(); \
++ irq_disable_hazard(); \
++ } while (0)
++
++/*
+ * The SMTC Kernel for the 34K, 1004K, et. al. replaces several
+ * of these routines with SMTC-specific variants.
+ */
+@@ -30,6 +46,7 @@ static int mips_next_event(unsigned long
+ cnt = read_c0_count();
+ cnt += delta;
+ write_c0_compare(cnt);
++ compare_change_hazard();
+ res = ((int)(read_c0_count() - cnt) > 0) ? -ETIME : 0;
+ return res;
+ }
+@@ -99,22 +116,6 @@ static int c0_compare_int_pending(void)
+ return (read_c0_cause() >> cp0_compare_irq) & 0x100;
+ }
+
+-/*
+- * Compare interrupt can be routed and latched outside the core,
+- * so a single execution hazard barrier may not be enough to give
+- * it time to clear as seen in the Cause register. 4 time the
+- * pipeline depth seems reasonably conservative, and empirically
+- * works better in configurations with high CPU/bus clock ratios.
+- */
+-
+-#define compare_change_hazard() \
+- do { \
+- irq_disable_hazard(); \
+- irq_disable_hazard(); \
+- irq_disable_hazard(); \
+- irq_disable_hazard(); \
+- } while (0)
+-
+ int c0_compare_int_usable(void)
+ {
+ unsigned int delta;