summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-2.6.29/006-ar71xx_wdt_driver.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2009-04-23 20:14:48 +0000
committerGabor Juhos <juhosg@openwrt.org>2009-04-23 20:14:48 +0000
commit8b82de7aa00be10315a8d1c514e3026ab590ce88 (patch)
tree643cfcebbb3de70623160f3bdea175c18676f3cd /target/linux/ar71xx/patches-2.6.29/006-ar71xx_wdt_driver.patch
parentb60fc68fa8587e17dc555b9163a86a3dbf93c922 (diff)
downloadmaster-31e0f0ae-8b82de7aa00be10315a8d1c514e3026ab590ce88.tar.gz
master-31e0f0ae-8b82de7aa00be10315a8d1c514e3026ab590ce88.tar.bz2
master-31e0f0ae-8b82de7aa00be10315a8d1c514e3026ab590ce88.zip
add initial support for 2.6.29
SVN-Revision: 15357
Diffstat (limited to 'target/linux/ar71xx/patches-2.6.29/006-ar71xx_wdt_driver.patch')
-rw-r--r--target/linux/ar71xx/patches-2.6.29/006-ar71xx_wdt_driver.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-2.6.29/006-ar71xx_wdt_driver.patch b/target/linux/ar71xx/patches-2.6.29/006-ar71xx_wdt_driver.patch
new file mode 100644
index 0000000000..60f6a6407c
--- /dev/null
+++ b/target/linux/ar71xx/patches-2.6.29/006-ar71xx_wdt_driver.patch
@@ -0,0 +1,26 @@
+--- a/drivers/watchdog/Kconfig
++++ b/drivers/watchdog/Kconfig
+@@ -766,6 +766,13 @@ config TXX9_WDT
+ help
+ Hardware driver for the built-in watchdog timer on TXx9 MIPS SoCs.
+
++config AR71XX_WDT
++ tristate "Atheros AR71xx Watchdog Timer"
++ depends on ATHEROS_AR71XX
++ help
++ Hardware driver for the built-in watchdog timer on the Atheros
++ AR71xx SoCs.
++
+ # PARISC Architecture
+
+ # POWERPC Architecture
+--- a/drivers/watchdog/Makefile
++++ b/drivers/watchdog/Makefile
+@@ -107,6 +107,7 @@ obj-$(CONFIG_WDT_RM9K_GPI) += rm9k_wdt.o
+ obj-$(CONFIG_SIBYTE_WDOG) += sb_wdog.o
+ obj-$(CONFIG_AR7_WDT) += ar7_wdt.o
+ obj-$(CONFIG_TXX9_WDT) += txx9wdt.o
++obj-$(CONFIG_AR71XX_WDT) += ar71xx_wdt.o
+
+ # PARISC Architecture
+