summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-2.6.28/204-rtl8366-smi-driver.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2009-12-08 10:29:35 +0000
committerGabor Juhos <juhosg@openwrt.org>2009-12-08 10:29:35 +0000
commitcc1b9a6046294c16db74592c0aa37545a5737291 (patch)
tree47f23a8aaf09fc664e8c7228e03e98a2fd35edd0 /target/linux/ar71xx/patches-2.6.28/204-rtl8366-smi-driver.patch
parent5c7ee7f0397deddf7245a560590edadb60019ed2 (diff)
downloadmaster-31e0f0ae-cc1b9a6046294c16db74592c0aa37545a5737291.tar.gz
master-31e0f0ae-cc1b9a6046294c16db74592c0aa37545a5737291.tar.bz2
master-31e0f0ae-cc1b9a6046294c16db74592c0aa37545a5737291.zip
ar71xx: add mdio bus driver for the rtl8366 switch
SVN-Revision: 18694
Diffstat (limited to 'target/linux/ar71xx/patches-2.6.28/204-rtl8366-smi-driver.patch')
-rw-r--r--target/linux/ar71xx/patches-2.6.28/204-rtl8366-smi-driver.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-2.6.28/204-rtl8366-smi-driver.patch b/target/linux/ar71xx/patches-2.6.28/204-rtl8366-smi-driver.patch
new file mode 100644
index 0000000000..afb3cbdb7b
--- /dev/null
+++ b/target/linux/ar71xx/patches-2.6.28/204-rtl8366-smi-driver.patch
@@ -0,0 +1,21 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -114,4 +114,8 @@ config MDIO_OF_GPIO
+ ---help---
+ Supports GPIO lib-based MDIO busses.
+
++config RTL8366_SMI
++ tristate "Support for RTL8366 switch via SMI interface"
++ depends on GENERIC_GPIO
++
+ endif # PHYLIB
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -17,6 +17,7 @@ obj-$(CONFIG_ADM6996_PHY) += adm6996.o
+ obj-$(CONFIG_IP175C_PHY) += ip175c.o
+ obj-$(CONFIG_RTL8306_PHY) += rtl8306.o
+ obj-$(CONFIG_REALTEK_PHY) += realtek.o
++obj-$(CONFIG_RTL8366_SMI) += rtl8366_smi.o
+ obj-$(CONFIG_MICREL_PHY) += micrel.o
+ obj-$(CONFIG_FIXED_PHY) += fixed.o
+ obj-$(CONFIG_MDIO_BITBANG) += mdio-bitbang.o