summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-2.6.28/202-spi_vsc7385_driver.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2009-06-06 04:43:55 +0000
committerGabor Juhos <juhosg@openwrt.org>2009-06-06 04:43:55 +0000
commit91aa0a7ca07219c2fef2686789813d98ad53b2f2 (patch)
treea0cf2544ea48d2757105bc0567911ece24f90cd9 /target/linux/ar71xx/patches-2.6.28/202-spi_vsc7385_driver.patch
parent4c9e3682cb405d850902b7d1c54e2c8a74cbb10c (diff)
downloadmaster-31e0f0ae-91aa0a7ca07219c2fef2686789813d98ad53b2f2.tar.gz
master-31e0f0ae-91aa0a7ca07219c2fef2686789813d98ad53b2f2.tar.bz2
master-31e0f0ae-91aa0a7ca07219c2fef2686789813d98ad53b2f2.zip
make the AP83 and VSC7385 SPI drivers available on 2.6.2[89]
SVN-Revision: 16351
Diffstat (limited to 'target/linux/ar71xx/patches-2.6.28/202-spi_vsc7385_driver.patch')
-rw-r--r--target/linux/ar71xx/patches-2.6.28/202-spi_vsc7385_driver.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-2.6.28/202-spi_vsc7385_driver.patch b/target/linux/ar71xx/patches-2.6.28/202-spi_vsc7385_driver.patch
new file mode 100644
index 0000000000..26f6156dab
--- /dev/null
+++ b/target/linux/ar71xx/patches-2.6.28/202-spi_vsc7385_driver.patch
@@ -0,0 +1,24 @@
+--- a/drivers/spi/Kconfig
++++ b/drivers/spi/Kconfig
+@@ -283,6 +283,11 @@ config SPI_TLE62X0
+ sysfs interface, with each line presented as a kind of GPIO
+ exposing both switch control and diagnostic feedback.
+
++config SPI_VSC7385
++ tristate "Vitesse VSC7385 ethernet switch driver"
++ help
++ SPI driver for the Vitesse VSC7385 ethernet switch.
++
+ #
+ # Add new SPI protocol masters in alphabetical order above this line
+ #
+--- a/drivers/spi/Makefile
++++ b/drivers/spi/Makefile
+@@ -38,6 +38,7 @@ obj-$(CONFIG_SPI_SH_SCI) += spi_sh_sci.
+ # SPI protocol drivers (device/link on bus)
+ obj-$(CONFIG_SPI_AT25) += at25.o
+ obj-$(CONFIG_SPI_SPIDEV) += spidev.o
++obj-$(CONFIG_SPI_VSC7385) += spi_vsc7385.o
+ obj-$(CONFIG_SPI_TLE62X0) += tle62x0.o
+ # ... add above this line ...
+