summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-2.6.28/004-ar71xx_spi_controller.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2008-12-09 08:11:49 +0000
committerGabor Juhos <juhosg@openwrt.org>2008-12-09 08:11:49 +0000
commita2cda74350e3fe7d984af8217f5b949422b62673 (patch)
tree8323a631ec4b53c1e4e99f78e0d50b4382e55a0e /target/linux/ar71xx/patches-2.6.28/004-ar71xx_spi_controller.patch
parent0de40f55dc5e818f91e2266790ca410502e9cee7 (diff)
downloadmaster-31e0f0ae-a2cda74350e3fe7d984af8217f5b949422b62673.tar.gz
master-31e0f0ae-a2cda74350e3fe7d984af8217f5b949422b62673.tar.bz2
master-31e0f0ae-a2cda74350e3fe7d984af8217f5b949422b62673.zip
preliminary 2.6.28 support
SVN-Revision: 13559
Diffstat (limited to 'target/linux/ar71xx/patches-2.6.28/004-ar71xx_spi_controller.patch')
-rw-r--r--target/linux/ar71xx/patches-2.6.28/004-ar71xx_spi_controller.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-2.6.28/004-ar71xx_spi_controller.patch b/target/linux/ar71xx/patches-2.6.28/004-ar71xx_spi_controller.patch
new file mode 100644
index 0000000000..9c196e077e
--- /dev/null
+++ b/target/linux/ar71xx/patches-2.6.28/004-ar71xx_spi_controller.patch
@@ -0,0 +1,26 @@
+--- a/drivers/spi/Kconfig
++++ b/drivers/spi/Kconfig
+@@ -53,6 +53,13 @@ if SPI_MASTER
+
+ comment "SPI Master Controller Drivers"
+
++config SPI_AR71XX
++ tristate "Atheros AR71xx SPI Controller"
++ depends on SPI_MASTER && ATHEROS_AR71XX
++ select SPI_BITBANG
++ help
++ This is the SPI contoller driver for Atheros AR71xx.
++
+ config SPI_ATMEL
+ tristate "Atmel SPI Controller"
+ depends on (ARCH_AT91 || AVR32)
+--- a/drivers/spi/Makefile
++++ b/drivers/spi/Makefile
+@@ -11,6 +11,7 @@ endif
+ obj-$(CONFIG_SPI_MASTER) += spi.o
+
+ # SPI master controller drivers (bus)
++obj-$(CONFIG_SPI_AR71XX) += ar71xx_spi.o
+ obj-$(CONFIG_SPI_ATMEL) += atmel_spi.o
+ obj-$(CONFIG_SPI_BFIN) += spi_bfin5xx.o
+ obj-$(CONFIG_SPI_BITBANG) += spi_bitbang.o