summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-2.6.27/200-rb4xx_nand_driver.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2008-10-05 06:29:44 +0000
committerGabor Juhos <juhosg@openwrt.org>2008-10-05 06:29:44 +0000
commit296a038de94e80ee57569369ab1b18a436c64ce2 (patch)
tree81ca9d30b1e15858068dba1043b3090abb4fcf06 /target/linux/ar71xx/patches-2.6.27/200-rb4xx_nand_driver.patch
parent12701b1d25861c613347a62f0725e900086cd9ee (diff)
downloadmaster-31e0f0ae-296a038de94e80ee57569369ab1b18a436c64ce2.tar.gz
master-31e0f0ae-296a038de94e80ee57569369ab1b18a436c64ce2.tar.bz2
master-31e0f0ae-296a038de94e80ee57569369ab1b18a436c64ce2.zip
experimental support for 2.6.27
SVN-Revision: 12859
Diffstat (limited to 'target/linux/ar71xx/patches-2.6.27/200-rb4xx_nand_driver.patch')
-rw-r--r--target/linux/ar71xx/patches-2.6.27/200-rb4xx_nand_driver.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-2.6.27/200-rb4xx_nand_driver.patch b/target/linux/ar71xx/patches-2.6.27/200-rb4xx_nand_driver.patch
new file mode 100644
index 0000000000..bc468ee0c4
--- /dev/null
+++ b/target/linux/ar71xx/patches-2.6.27/200-rb4xx_nand_driver.patch
@@ -0,0 +1,21 @@
+--- a/drivers/mtd/nand/Kconfig
++++ b/drivers/mtd/nand/Kconfig
+@@ -406,4 +406,8 @@
+ Enables support for NAND Flash chips wired onto Freescale PowerPC
+ processor localbus with User-Programmable Machine support.
+
++config MTD_NAND_RB4XX
++ tristate "NAND flash driver for RouterBoard 4xx series"
++ depends on MTD_NAND && ATHEROS_AR71XX
++
+ endif # MTD_NAND
+--- a/drivers/mtd/nand/Makefile
++++ b/drivers/mtd/nand/Makefile
+@@ -29,6 +29,7 @@
+ obj-$(CONFIG_MTD_NAND_PXA3xx) += pxa3xx_nand.o
+ obj-$(CONFIG_MTD_NAND_TMIO) += tmio_nand.o
+ obj-$(CONFIG_MTD_NAND_PLATFORM) += plat_nand.o
++obj-$(CONFIG_MTD_NAND_RB4XX) += rb4xx_nand.o
+ obj-$(CONFIG_MTD_ALAUDA) += alauda.o
+ obj-$(CONFIG_MTD_NAND_PASEMI) += pasemi_nand.o
+ obj-$(CONFIG_MTD_NAND_ORION) += orion_nand.o