summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-2.6.27/101-ksz8041_phy_driver.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2008-10-05 06:29:44 +0000
committerGabor Juhos <juhosg@openwrt.org>2008-10-05 06:29:44 +0000
commit296a038de94e80ee57569369ab1b18a436c64ce2 (patch)
tree81ca9d30b1e15858068dba1043b3090abb4fcf06 /target/linux/ar71xx/patches-2.6.27/101-ksz8041_phy_driver.patch
parent12701b1d25861c613347a62f0725e900086cd9ee (diff)
downloadmaster-31e0f0ae-296a038de94e80ee57569369ab1b18a436c64ce2.tar.gz
master-31e0f0ae-296a038de94e80ee57569369ab1b18a436c64ce2.tar.bz2
master-31e0f0ae-296a038de94e80ee57569369ab1b18a436c64ce2.zip
experimental support for 2.6.27
SVN-Revision: 12859
Diffstat (limited to 'target/linux/ar71xx/patches-2.6.27/101-ksz8041_phy_driver.patch')
-rw-r--r--target/linux/ar71xx/patches-2.6.27/101-ksz8041_phy_driver.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-2.6.27/101-ksz8041_phy_driver.patch b/target/linux/ar71xx/patches-2.6.27/101-ksz8041_phy_driver.patch
new file mode 100644
index 0000000000..0797505023
--- /dev/null
+++ b/target/linux/ar71xx/patches-2.6.27/101-ksz8041_phy_driver.patch
@@ -0,0 +1,24 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -77,6 +77,11 @@
+ ---help---
+ Currently supports the Marvell 88E6060 switch.
+
++config MICREL_PHY
++ tristate "Drivers for Micrel/Kendin PHYs"
++ ---help---
++ Currently has a driver for the KSZ8041
++
+ config FIXED_PHY
+ bool "Driver for MDIO Bus/PHY emulation with fixed speed/link PHYs"
+ depends on PHYLIB=y
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -15,6 +15,7 @@
+ obj-$(CONFIG_ADM6996_PHY) += adm6996.o
+ obj-$(CONFIG_MVSWITCH_PHY) += mvswitch.o
+ obj-$(CONFIG_REALTEK_PHY) += realtek.o
++obj-$(CONFIG_MICREL_PHY) += micrel.o
+ obj-$(CONFIG_FIXED_PHY) += fixed.o
+ obj-$(CONFIG_MDIO_BITBANG) += mdio-bitbang.o
+ obj-$(CONFIG_MDIO_OF_GPIO) += mdio-ofgpio.o