summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/nand
diff options
context:
space:
mode:
authorJohn Crispin <john@phrozen.org>2016-06-23 19:33:07 +0200
committerJohn Crispin <john@phrozen.org>2016-06-23 19:33:31 +0200
commit387477350334daf8cd6adf72f63eddae83785614 (patch)
treeffa65aadbb9341ec560af9cd21879e8822e46ac2 /target/linux/ar71xx/nand
parentcb7aa4b1fee688342950d02195b927962295514e (diff)
downloadmaster-31e0f0ae-387477350334daf8cd6adf72f63eddae83785614.tar.gz
master-31e0f0ae-387477350334daf8cd6adf72f63eddae83785614.tar.bz2
master-31e0f0ae-387477350334daf8cd6adf72f63eddae83785614.zip
Revert "ar71xx: fix legacy image building"
This reverts commit 59e98b27c93d282edb62fad756fd1c1e587c067f. and Revert "ar71xx: merge profiles into image building code" This reverts commit 636089ead6864364798ac988299429d171051c0e. these are still causing issues Signed-off-by: John Crispin <john@phrozen.org>
Diffstat (limited to 'target/linux/ar71xx/nand')
-rw-r--r--target/linux/ar71xx/nand/profiles/meraki.mk17
-rw-r--r--target/linux/ar71xx/nand/profiles/netgear.mk29
-rw-r--r--target/linux/ar71xx/nand/profiles/zyxel.mk18
3 files changed, 64 insertions, 0 deletions
diff --git a/target/linux/ar71xx/nand/profiles/meraki.mk b/target/linux/ar71xx/nand/profiles/meraki.mk
new file mode 100644
index 0000000000..2c848c994c
--- /dev/null
+++ b/target/linux/ar71xx/nand/profiles/meraki.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2014-2015 Chris Blake (chrisrblake93@gmail.com)
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/MR18
+ NAME:=Meraki MR18
+ PACKAGES:=kmod-spi-gpio kmod-ath9k
+endef
+
+define Profile/MR18/description
+ Package set optimized for the Cisco Meraki MR18 Access Point.
+endef
+
+$(eval $(call Profile,MR18))
diff --git a/target/linux/ar71xx/nand/profiles/netgear.mk b/target/linux/ar71xx/nand/profiles/netgear.mk
new file mode 100644
index 0000000000..738aaba2c1
--- /dev/null
+++ b/target/linux/ar71xx/nand/profiles/netgear.mk
@@ -0,0 +1,29 @@
+#
+# Copyright (C) 2009-2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/R6100
+ NAME:=NETGEAR R6100
+ PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-ledtrig-usbdev
+endef
+
+define Profile/R6100/Description
+ Package set optimized for the NETGEAR R6100
+endef
+
+$(eval $(call Profile,R6100))
+
+
+define Profile/WNDR4300
+ NAME:=NETGEAR WNDR3700v4/WNDR4300
+ PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-ledtrig-usbdev
+endef
+
+define Profile/WNDR4300/Description
+ Package set optimized for the NETGEAR WNDR3700v4/WNDR4300
+endef
+
+$(eval $(call Profile,WNDR4300))
diff --git a/target/linux/ar71xx/nand/profiles/zyxel.mk b/target/linux/ar71xx/nand/profiles/zyxel.mk
new file mode 100644
index 0000000000..ec813e548f
--- /dev/null
+++ b/target/linux/ar71xx/nand/profiles/zyxel.mk
@@ -0,0 +1,18 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/NBG6716
+ NAME:=Zyxel NBG 6716
+ PACKAGES:=kmod-rtc-pcf8563 kmod-ath10k
+endef
+
+define Profile/NBG6716/Description
+ Package set optimized for the Zyxel NBG 6716 Routers.
+endef
+
+$(eval $(call Profile,NBG6716))
+