summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/nand
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2010-05-07 16:20:32 +0000
committerFelix Fietkau <nbd@openwrt.org>2010-05-07 16:20:32 +0000
commit2598c32f063f410ee32fe967db85a02432992269 (patch)
treea49faf7fc0079043cc3621974bbdab59e5c18ba9 /target/linux/ar71xx/nand
parent0f7864456a60f1ea4a5a2ce7aa4f99d68bd4a1d9 (diff)
downloadmaster-31e0f0ae-2598c32f063f410ee32fe967db85a02432992269.tar.gz
master-31e0f0ae-2598c32f063f410ee32fe967db85a02432992269.tar.bz2
master-31e0f0ae-2598c32f063f410ee32fe967db85a02432992269.zip
ar71xx: add a new subtarget for nand based devices - saves around 44k on the lzma compressed generic kernel image
SVN-Revision: 21396
Diffstat (limited to 'target/linux/ar71xx/nand')
-rw-r--r--target/linux/ar71xx/nand/config-default13
-rw-r--r--target/linux/ar71xx/nand/profiles/01-minimal.mk16
-rw-r--r--target/linux/ar71xx/nand/profiles/02-madwifi.mk16
-rw-r--r--target/linux/ar71xx/nand/target.mk8
4 files changed, 53 insertions, 0 deletions
diff --git a/target/linux/ar71xx/nand/config-default b/target/linux/ar71xx/nand/config-default
new file mode 100644
index 0000000000..3fa8d7b160
--- /dev/null
+++ b/target/linux/ar71xx/nand/config-default
@@ -0,0 +1,13 @@
+CONFIG_MTD_NAND=y
+CONFIG_MTD_NAND_RB4XX=y
+CONFIG_MTD_NAND_RB750=y
+CONFIG_YAFFS_9BYTE_TAGS=y
+CONFIG_YAFFS_ALWAYS_CHECK_CHUNK_ERASED=y
+CONFIG_YAFFS_AUTO_YAFFS2=y
+# CONFIG_YAFFS_DISABLE_LAZY_LOAD is not set
+# CONFIG_YAFFS_DISABLE_WIDE_TNODES is not set
+CONFIG_YAFFS_FS=y
+CONFIG_YAFFS_SHORT_NAMES_IN_RAM=y
+CONFIG_YAFFS_YAFFS1=y
+CONFIG_YAFFS_YAFFS2=y
+
diff --git a/target/linux/ar71xx/nand/profiles/01-minimal.mk b/target/linux/ar71xx/nand/profiles/01-minimal.mk
new file mode 100644
index 0000000000..3651c88ab2
--- /dev/null
+++ b/target/linux/ar71xx/nand/profiles/01-minimal.mk
@@ -0,0 +1,16 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/DefaultNoWifi
+ NAME:=Default Profile (no WiFi)
+ PACKAGES:=
+endef
+
+define Profile/DefaultNoWifi/Description
+ Default package set compatible with most boards.
+endef
+$(eval $(call Profile,DefaultNoWifi))
diff --git a/target/linux/ar71xx/nand/profiles/02-madwifi.mk b/target/linux/ar71xx/nand/profiles/02-madwifi.mk
new file mode 100644
index 0000000000..7c22c53db5
--- /dev/null
+++ b/target/linux/ar71xx/nand/profiles/02-madwifi.mk
@@ -0,0 +1,16 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Madwifi
+ NAME:=Atheros WiFi (madwifi)
+ PACKAGES:=kmod-madwifi wpad-mini
+endef
+
+define Profile/Madwifi/Description
+ Package set compatible with hardware using Atheros WiFi cards.
+endef
+$(eval $(call Profile,Madwifi))
diff --git a/target/linux/ar71xx/nand/target.mk b/target/linux/ar71xx/nand/target.mk
new file mode 100644
index 0000000000..f01ef645fa
--- /dev/null
+++ b/target/linux/ar71xx/nand/target.mk
@@ -0,0 +1,8 @@
+BOARDNAME:=Devices with NAND flash
+
+define Target/Description
+ Build firmware images for Atheros AR71xx/AR913x based boards with
+ NAND flash, e.g. MikroTik RB-4xx or RB-750
+endef
+
+