summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/modules.mk
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-11-01 18:33:18 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-11-01 18:33:18 +0000
commitb2bc45d21e058f5e447f76425e98dec7d817dfae (patch)
tree3105b49e01195d14b27663e2987f55f058019107 /target/linux/ar71xx/modules.mk
parent0e655122c64b3c3885df8e03741a4e1bdc568623 (diff)
downloadmaster-31e0f0ae-b2bc45d21e058f5e447f76425e98dec7d817dfae.tar.gz
master-31e0f0ae-b2bc45d21e058f5e447f76425e98dec7d817dfae.tar.bz2
master-31e0f0ae-b2bc45d21e058f5e447f76425e98dec7d817dfae.zip
ar71xx: always enable hw ecc support for the ar934x-nfc module
Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 38634
Diffstat (limited to 'target/linux/ar71xx/modules.mk')
-rw-r--r--target/linux/ar71xx/modules.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/target/linux/ar71xx/modules.mk b/target/linux/ar71xx/modules.mk
index 83747d6ce2..4530708de9 100644
--- a/target/linux/ar71xx/modules.mk
+++ b/target/linux/ar71xx/modules.mk
@@ -40,7 +40,9 @@ $(eval $(call KernelPackage,leds-wndr3700-usb))
define KernelPackage/nand-ar934x
SUBMENU:=$(OTHER_MENU)
TITLE:=Atheros AR934x NAND flash controller driver
- KCONFIG:=CONFIG_MTD_NAND_AR934X
+ KCONFIG:=\
+ CONFIG_MTD_NAND_AR934X \
+ CONFIG_MTD_NAND_AR934X_HW_ECC=y
DEPENDS:=@TARGET_ar71xx +kmod-nand
FILES:=$(LINUX_DIR)/drivers/mtd/nand/ar934x_nfc.ko
AUTOLOAD:=$(call AutoLoad,25,ar934x_nfc)