summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/modules.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-06-07 07:22:11 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-06-07 07:22:11 +0000
commit7138c77f5aa347ed310c28df05caec19a6425649 (patch)
tree49a0b431ccf83da372dc695927c8ea98c0ff5884 /target/linux/ar71xx/modules.mk
parentbd87d11e58637a9d3a6db9340213fa2bf05caa06 (diff)
downloadmaster-31e0f0ae-7138c77f5aa347ed310c28df05caec19a6425649.tar.gz
master-31e0f0ae-7138c77f5aa347ed310c28df05caec19a6425649.tar.bz2
master-31e0f0ae-7138c77f5aa347ed310c28df05caec19a6425649.zip
kernel: remove NAND flash related kmod-* packages
They are useless, as the platform already selects the right options for NAND support. The main reason for removing them is the fact that it makes kernel configs more annoying to maintain on platforms that provide NAND drivers but disable them (e.g. ramips) Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 45919
Diffstat (limited to 'target/linux/ar71xx/modules.mk')
-rw-r--r--target/linux/ar71xx/modules.mk18
1 files changed, 0 insertions, 18 deletions
diff --git a/target/linux/ar71xx/modules.mk b/target/linux/ar71xx/modules.mk
index 4530708de9..a6a13d2613 100644
--- a/target/linux/ar71xx/modules.mk
+++ b/target/linux/ar71xx/modules.mk
@@ -37,24 +37,6 @@ endef
$(eval $(call KernelPackage,leds-wndr3700-usb))
-define KernelPackage/nand-ar934x
- SUBMENU:=$(OTHER_MENU)
- TITLE:=Atheros AR934x NAND flash controller driver
- KCONFIG:=\
- CONFIG_MTD_NAND_AR934X \
- CONFIG_MTD_NAND_AR934X_HW_ECC=y
- DEPENDS:=@TARGET_ar71xx +kmod-nand
- FILES:=$(LINUX_DIR)/drivers/mtd/nand/ar934x_nfc.ko
- AUTOLOAD:=$(call AutoLoad,25,ar934x_nfc)
-endef
-
-define KernelPackage/nand-ar934x/description
- Atheros AR934x NAND flash controller driver.
-endef
-
-$(eval $(call KernelPackage,nand-ar934x))
-
-
define KernelPackage/spi-vsc7385
SUBMENU:=$(SPI_MENU)
TITLE:=Vitesse VSC7385 ethernet switch driver