summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/modules.mk
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-12-11 15:04:57 +0000
committerJohn Crispin <john@openwrt.org>2015-12-11 15:04:57 +0000
commit1dada3fc3c08b9f7fe12219af238d408409c5fa1 (patch)
treee5f2c90dec102835c14656298e780bd1548e345d /target/linux/ar71xx/modules.mk
parenteb8ff566848fce7c9d2c16c3eb7c22559a9fae0e (diff)
downloadmaster-31e0f0ae-1dada3fc3c08b9f7fe12219af238d408409c5fa1.tar.gz
master-31e0f0ae-1dada3fc3c08b9f7fe12219af238d408409c5fa1.tar.bz2
master-31e0f0ae-1dada3fc3c08b9f7fe12219af238d408409c5fa1.zip
ar71xx: add LED driver NU801
The MR18 uses a 3-channel 16-bit PWM Constant Current Driver for its status LED. Signed-off-by: Chris R Blake <chrisrblake93@gmail.com> SVN-Revision: 47848
Diffstat (limited to 'target/linux/ar71xx/modules.mk')
-rw-r--r--target/linux/ar71xx/modules.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/target/linux/ar71xx/modules.mk b/target/linux/ar71xx/modules.mk
index a6a13d2613..9ead8b451c 100644
--- a/target/linux/ar71xx/modules.mk
+++ b/target/linux/ar71xx/modules.mk
@@ -5,6 +5,22 @@
# See /LICENSE for more information.
#
+define KernelPackage/leds-nu801
+ SUBMENU:=$(LEDS_MENU)
+ TITLE:=Meraki MR18 LED support
+ DEPENDS:=@TARGET_ar71xx
+ KCONFIG:=CONFIG_LEDS_NU801
+ FILES:=$(LINUX_DIR)/drivers/leds/leds-nu801.ko
+ AUTOLOAD:=$(call AutoLoad,60,leds-nu801)
+endef
+
+define KernelPackage/leds-nu801/description
+ Kernel module for the nu801 LED driver used on the Meraki MR18.
+endef
+
+$(eval $(call KernelPackage,leds-nu801))
+
+
define KernelPackage/leds-rb750
SUBMENU:=$(LEDS_MENU)
TITLE:=RouterBOARD 750 LED support