summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/mikrotik
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-10-23 15:43:26 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-10-23 15:43:26 +0000
commit9e01011b5ca289484d302983ed277aeeb3417b24 (patch)
tree606323b36e94772b89d0d8dac199d2f0a94df939 /target/linux/ar71xx/mikrotik
parent757a6fdef9f60f789abf8187c52ac50354bbd09e (diff)
downloadmaster-31e0f0ae-9e01011b5ca289484d302983ed277aeeb3417b24.tar.gz
master-31e0f0ae-9e01011b5ca289484d302983ed277aeeb3417b24.tar.bz2
master-31e0f0ae-9e01011b5ca289484d302983ed277aeeb3417b24.zip
ar71xx: rename 'nand' subtarget to 'mikrotik'
It is for Mikrotik devices only, rename the subtarget to reflect that. Also fix the wget2nand script to use the new image names. Based on the patch by Stefan Agner: http://patchwork.openwrt.org/patch/4123/ Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 38509
Diffstat (limited to 'target/linux/ar71xx/mikrotik')
-rw-r--r--target/linux/ar71xx/mikrotik/config-default34
-rw-r--r--target/linux/ar71xx/mikrotik/profiles/01-minimal.mk16
-rw-r--r--target/linux/ar71xx/mikrotik/profiles/02-ath5k.mk16
-rw-r--r--target/linux/ar71xx/mikrotik/target.mk8
4 files changed, 74 insertions, 0 deletions
diff --git a/target/linux/ar71xx/mikrotik/config-default b/target/linux/ar71xx/mikrotik/config-default
new file mode 100644
index 0000000000..efa562c66e
--- /dev/null
+++ b/target/linux/ar71xx/mikrotik/config-default
@@ -0,0 +1,34 @@
+CONFIG_ATH79_MACH_RB2011=y
+CONFIG_ATH79_MACH_RB4XX=y
+CONFIG_ATH79_MACH_RB750=y
+CONFIG_ATH79_MACH_RB95X=y
+CONFIG_ATH79_ROUTERBOOT=y
+CONFIG_CMDLINE="rootfstype=yaffs noinitrd"
+# CONFIG_JFFS2_FS is not set
+CONFIG_LEDS_RB750=y
+CONFIG_MDIO_BITBANG=y
+CONFIG_MDIO_GPIO=y
+CONFIG_MTD_NAND=y
+CONFIG_MTD_NAND_AR934X=y
+CONFIG_MTD_NAND_ECC=y
+CONFIG_MTD_NAND_RB4XX=y
+CONFIG_MTD_NAND_RB750=y
+# CONFIG_MTD_SM_COMMON is not set
+# CONFIG_OVERLAYFS_FS is not set
+CONFIG_RLE_DECOMPRESS=y
+CONFIG_SPI_RB4XX=y
+CONFIG_SPI_RB4XX_CPLD=y
+# CONFIG_SQUASHFS is not set
+CONFIG_YAFFS_9BYTE_TAGS=y
+CONFIG_YAFFS_ALWAYS_CHECK_CHUNK_ERASED=y
+CONFIG_YAFFS_AUTO_YAFFS2=y
+# CONFIG_YAFFS_DISABLE_BACKGROUND is not set
+# CONFIG_YAFFS_DISABLE_BLOCK_REFRESHING is not set
+# CONFIG_YAFFS_DISABLE_TAGS_ECC is not set
+# CONFIG_YAFFS_DISABLE_WIDE_TNODES is not set
+# CONFIG_YAFFS_EMPTY_LOST_AND_FOUND is not set
+CONFIG_YAFFS_FS=y
+CONFIG_YAFFS_SHORT_NAMES_IN_RAM=y
+CONFIG_YAFFS_XATTR=y
+CONFIG_YAFFS_YAFFS1=y
+CONFIG_YAFFS_YAFFS2=y
diff --git a/target/linux/ar71xx/mikrotik/profiles/01-minimal.mk b/target/linux/ar71xx/mikrotik/profiles/01-minimal.mk
new file mode 100644
index 0000000000..3651c88ab2
--- /dev/null
+++ b/target/linux/ar71xx/mikrotik/profiles/01-minimal.mk
@@ -0,0 +1,16 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/DefaultNoWifi
+ NAME:=Default Profile (no WiFi)
+ PACKAGES:=
+endef
+
+define Profile/DefaultNoWifi/Description
+ Default package set compatible with most boards.
+endef
+$(eval $(call Profile,DefaultNoWifi))
diff --git a/target/linux/ar71xx/mikrotik/profiles/02-ath5k.mk b/target/linux/ar71xx/mikrotik/profiles/02-ath5k.mk
new file mode 100644
index 0000000000..a291ff68ae
--- /dev/null
+++ b/target/linux/ar71xx/mikrotik/profiles/02-ath5k.mk
@@ -0,0 +1,16 @@
+#
+# Copyright (C) 2009-2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Ath5k
+ NAME:=Atheros WiFi (ath5k)
+ PACKAGES:=kmod-ath5k -kmod-ath9k
+endef
+
+define Profile/Ath5k/Description
+ Package set compatible with hardware using Atheros WiFi cards.
+endef
+$(eval $(call Profile,Ath5k))
diff --git a/target/linux/ar71xx/mikrotik/target.mk b/target/linux/ar71xx/mikrotik/target.mk
new file mode 100644
index 0000000000..45d2624cd4
--- /dev/null
+++ b/target/linux/ar71xx/mikrotik/target.mk
@@ -0,0 +1,8 @@
+BOARDNAME:=Mikrotik devices with NAND flash
+
+define Target/Description
+ Build firmware images for Atheros AR71xx/AR913x based Mikrotik boards.
+ e.g. MikroTik RB-4xx or RB-750
+endef
+
+