summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2008-07-21 17:08:14 +0000
committerGabor Juhos <juhosg@openwrt.org>2008-07-21 17:08:14 +0000
commitf529a3742043a23da4f715c3664d5a822b1f970c (patch)
treea4cdaee84e23765d98072df25883f365cbc0d66a /target/linux/ar71xx/image
parent3d9c4c9073deaf01d592d6940af21be81d92e88a (diff)
downloadmaster-31e0f0ae-f529a3742043a23da4f715c3664d5a822b1f970c.tar.gz
master-31e0f0ae-f529a3742043a23da4f715c3664d5a822b1f970c.tar.bz2
master-31e0f0ae-f529a3742043a23da4f715c3664d5a822b1f970c.zip
surprise :p
SVN-Revision: 11894
Diffstat (limited to 'target/linux/ar71xx/image')
-rw-r--r--target/linux/ar71xx/image/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
new file mode 100644
index 0000000000..4d86889a5e
--- /dev/null
+++ b/target/linux/ar71xx/image/Makefile
@@ -0,0 +1,28 @@
+#
+# Copyright (C) 2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/image.mk
+
+define Image/BuildKernel
+ cp $(KDIR)/vmlinux.elf $(BIN_DIR)/openwrt-$(BOARD)-vmlinux.elf
+ gzip -9 -c $(KDIR)/vmlinux > $(KDIR)/vmlinux.bin.gz
+ $(STAGING_DIR_HOST)/bin/lzma e $(KDIR)/vmlinux $(KDIR)/vmlinux.bin.l7
+ dd if=$(KDIR)/vmlinux.bin.l7 of=$(BIN_DIR)/openwrt-$(BOARD)-vmlinux.lzma bs=65536 conv=sync
+ dd if=$(KDIR)/vmlinux.bin.gz of=$(BIN_DIR)/openwrt-$(BOARD)-vmlinux.gz bs=65536 conv=sync
+endef
+
+define Image/Build/squashfs
+ $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
+endef
+
+define Image/Build
+ $(call Image/Build/$(1))
+ dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-root.$(1) bs=128k conv=sync
+endef
+
+
+$(eval $(call BuildImage))