summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image
diff options
context:
space:
mode:
authorPiotr Dymacz <pepe2k@gmail.com>2016-08-18 00:05:03 +0200
committerJohn Crispin <john@phrozen.org>2016-08-18 09:49:18 +0200
commitf478fba663d3ea1bf919137277b9a81344006173 (patch)
tree73907f5cdf110c0e8992b64e13a54c11f5c5c004 /target/linux/ar71xx/image
parent57ef81d78f590c86aaebeb41c14528b33b73db94 (diff)
downloadmaster-31e0f0ae-f478fba663d3ea1bf919137277b9a81344006173.tar.gz
master-31e0f0ae-f478fba663d3ea1bf919137277b9a81344006173.tar.bz2
master-31e0f0ae-f478fba663d3ea1bf919137277b9a81344006173.zip
ar71xx: add support for Zbtlink ZBT-WE1526
Zbtlink ZBT-WE1526 is based on Qualcomm Atheros QCA9531 v2. Short specification: - 650/400/200 MHz (CPU/DDR/AHB) - 5x 10/100 Mbps Ethernet - 1x USB 2.0 - 128 MB of RAM (DDR2) - 16 MB of FLASH - 2T2R 2.4 GHz, up to 22 dBm - two external, non-detachable antennas - 8x LED, 1x button - UART header (pinout: VCC, RX, TX, GND) Flash instruction: Use sysupgrade in vendor firmare which is based on OpenWrt. Signed-off-by: Piotr Dymacz <pepe2k@gmail.com>
Diffstat (limited to 'target/linux/ar71xx/image')
-rw-r--r--target/linux/ar71xx/image/legacy-devices.mk6
-rw-r--r--target/linux/ar71xx/image/legacy.mk1
2 files changed, 7 insertions, 0 deletions
diff --git a/target/linux/ar71xx/image/legacy-devices.mk b/target/linux/ar71xx/image/legacy-devices.mk
index 1d295f1006..72114cdce9 100644
--- a/target/linux/ar71xx/image/legacy-devices.mk
+++ b/target/linux/ar71xx/image/legacy-devices.mk
@@ -705,6 +705,12 @@ define LegacyDevice/WZR450HP2
endef
LEGACY_DEVICES += WZR450HP2
+define LegacyDevice/ZBTWE1526
+ DEVICE_TITLE := Zbtlink ZBT-WE1526
+ DEVICE_PACKAGES := kmod-usb-core kmod-usb2
+endef
+LEGACY_DEVICES += ZBTWE1526
+
define LegacyDevice/ZCN1523H28
DEVICE_TITLE := Zcomax ZCN-1523H-2-8
endef
diff --git a/target/linux/ar71xx/image/legacy.mk b/target/linux/ar71xx/image/legacy.mk
index c2daba9f60..03af6582c4 100644
--- a/target/linux/ar71xx/image/legacy.mk
+++ b/target/linux/ar71xx/image/legacy.mk
@@ -964,6 +964,7 @@ $(eval $(call SingleProfile,AthLzma,64k,WPJ558_16M,wpj558-16M,WPJ558,ttyS0,11520
$(eval $(call SingleProfile,AthLzma,64k,WRTNODE2Q,wrtnode2q,WRTNODE2Q,ttyS0,115200,$$(wrtnode2q_mtdlayout),KRuImage))
$(eval $(call SingleProfile,AthLzma,64k,YUN_8M,yun-8M,Yun,ttyATH0,250000,$$(yun_mtdlayout_8M),RKuImage))
$(eval $(call SingleProfile,AthLzma,64k,YUN_16M,yun-16M,Yun,ttyATH0,250000,$$(yun_mtdlayout_16M),RKuImage))
+$(eval $(call SingleProfile,AthLzma,64k,ZBTWE1526,zbt-we1526,ZBT-WE1526,ttyS0,115200,$$(ap147_mtdlayout),RKuImage))
$(eval $(call SingleProfile,Belkin,64k,F9K1115V2,f9k1115v2,F9K1115V2,ttyS0,115200,$$(f9k1115v2_mtdlayout),BR-6679BAC))