summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-01-31 18:37:01 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-01-31 18:37:01 +0000
commit97e4ddd012546ecaf5dea609af784e339408e502 (patch)
tree8eac46502e53997f4879ba1ffb09f53d89a89364 /target/linux/ar71xx/image
parent8766f32b8c10ec8f5a34c794397e90d8f9d5796a (diff)
downloadmaster-31e0f0ae-97e4ddd012546ecaf5dea609af784e339408e502.tar.gz
master-31e0f0ae-97e4ddd012546ecaf5dea609af784e339408e502.tar.bz2
master-31e0f0ae-97e4ddd012546ecaf5dea609af784e339408e502.zip
ar71xx: add support for TP-Link TL-MR11U
Adds support for TL-MR11U, a portable router with very similar hardware to the TL-WR703N and TL-MR3020, but with an onboard 2000mAh battery. Tested, working: All interfaces (Ethernet, 802.11n, USB) WPS & Reset switches (Power appears to be a hardware slider) Ethernet, Wifi, 3G LEDs (Power & charging LEDs hardware controlled) Sysupgrade [juhosg: fix indentations to use TABs instead of spaces, fix 3.2 patch breakage] Signed-off-by: Simon Taylor <simon.taylor.uk@gmail.com> SVN-Revision: 29972
Diffstat (limited to 'target/linux/ar71xx/image')
-rw-r--r--target/linux/ar71xx/image/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index c3dc8a058d..bd5e945f59 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -819,6 +819,11 @@ define Image/Build/Profile/OM2P
$(call Image/Build/Template/$(fs_squash)/$(1),OpenMesh,om2p,OM2P)
endef
+tlmr11u_cmdline=board=TL-MR11U console=ttyATH0,115200
+define Image/Build/Profile/TLMR11U
+ $(call Image/Build/Template/$(fs_64kraw)/$(1),TPLINK-LZMA,tl-mr11u-v1,$(tlmr11u_cmdline),0x00110101,1,4Mlzma)
+endef
+
tlmr3020_cmdline=board=TL-MR3020 console=ttyATH0,115200
define Image/Build/Profile/TLMR3020
$(call Image/Build/Template/$(fs_64k)/$(1),TPLINK-LZMA,tl-mr3020-v1,$(tlmr3020_cmdline),0x30200001,1,4Mlzma)
@@ -1006,6 +1011,7 @@ define Image/Build/Profile/Default
$(call Image/Build/Profile/RW2458N,$(1))
$(call Image/Build/Profile/TEW632BRP,$(1))
$(call Image/Build/Profile/TEW652BRP,$(1))
+ $(call Image/Build/Profile/TLMR11U,$(1))
$(call Image/Build/Profile/TLMR3020,$(1))
$(call Image/Build/Profile/TLMR3220,$(1))
$(call Image/Build/Profile/TLMR3420,$(1))