summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-05-23 21:05:24 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-05-23 21:05:24 +0000
commit758f670376db2b4504d4d3fc22b55793effef6d0 (patch)
treedf620e48b5c2fdff6e52bf381108c9700338af5b /target/linux/ar71xx/image
parente4720dfa9594cb75ef6691e669f81e8207a00e39 (diff)
downloadmaster-31e0f0ae-758f670376db2b4504d4d3fc22b55793effef6d0.tar.gz
master-31e0f0ae-758f670376db2b4504d4d3fc22b55793effef6d0.tar.bz2
master-31e0f0ae-758f670376db2b4504d4d3fc22b55793effef6d0.zip
ar71xx: add support for TP-Link TL-MR3040
Support for TP-Link TL-MR3040. Power LED not working - always on red, after start should be green. Signed-off-by: Cezary Jackiewicz <cezary.jackiewicz@gmail.com> SVN-Revision: 31845
Diffstat (limited to 'target/linux/ar71xx/image')
-rw-r--r--target/linux/ar71xx/image/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index f99c01ab15..2f6a161cfd 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -877,6 +877,11 @@ define Image/Build/Profile/TLMR3020
$(call Image/Build/Template/$(fs_64k)/$(1),TPLINK-LZMA,tl-mr3020-v1,$(tlmr3020_cmdline),0x30200001,1,4Mlzma)
endef
+tlmr3040_cmdline=board=TL-MR11U console=ttyATH0,115200
+define Image/Build/Profile/TLMR3040
+ $(call Image/Build/Template/$(fs_64kraw)/$(1),TPLINK-LZMA,tl-mr3040-v1,$(tlmr3040_cmdline),0x30400001,1,4Mlzma)
+endef
+
tlmr3220_cmdline=board=TL-MR3220 console=ttyS0,115200
define Image/Build/Profile/TLMR3220
$(call Image/Build/Template/$(fs_64kraw)/$(1),TPLINK,tl-mr3220-v1,$(tlmr3220_cmdline),0x32200001,1,4M)
@@ -1081,6 +1086,7 @@ define Image/Build/Profile/Default
$(call Image/Build/Profile/TEW673GRU,$(1))
$(call Image/Build/Profile/TLMR11U,$(1))
$(call Image/Build/Profile/TLMR3020,$(1))
+ $(call Image/Build/Profile/TLMR3040,$(1))
$(call Image/Build/Profile/TLMR3220,$(1))
$(call Image/Build/Profile/TLMR3420,$(1))
$(call Image/Build/Profile/TLWA701,$(1))