summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-05-23 17:59:37 +0200
committerFelix Fietkau <nbd@nbd.name>2016-06-07 08:58:41 +0200
commit4c5a49031eb690f1f311c9e8d4c68c541fadf5ae (patch)
tree638ad87fc0d7fdee853274bff5748b7936f5341d /target/linux/ar71xx/image
parent26c771452cd8d13f3b07eac1e674bd7c56398110 (diff)
downloadmaster-31e0f0ae-4c5a49031eb690f1f311c9e8d4c68c541fadf5ae.tar.gz
master-31e0f0ae-4c5a49031eb690f1f311c9e8d4c68c541fadf5ae.tar.bz2
master-31e0f0ae-4c5a49031eb690f1f311c9e8d4c68c541fadf5ae.zip
ar71xx: convert OM2P to device profile
Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'target/linux/ar71xx/image')
-rw-r--r--target/linux/ar71xx/image/legacy.mk15
1 files changed, 15 insertions, 0 deletions
diff --git a/target/linux/ar71xx/image/legacy.mk b/target/linux/ar71xx/image/legacy.mk
index 7e3f2934d4..cf3183e67a 100644
--- a/target/linux/ar71xx/image/legacy.mk
+++ b/target/linux/ar71xx/image/legacy.mk
@@ -1164,6 +1164,12 @@ $(eval $(call MultiProfile,Yun,YUN_16M YUN_8M))
$(eval $(call MultiProfile,Minimal,$(SINGLE_PROFILES)))
$(eval $(call MultiProfile,Madwifi,EAP7660D WP543))
+define LegacyDevice/OM2P
+ DEVICE_TITLE := OpenMesh OM2P/OM2Pv2/OM2P-HS/OM2P-HSv2/OM2P-HSv3/OM2P-LC
+ DEVICE_PACKAGES := kmod-ath9k om-watchdog
+endef
+LEGACY_DEVICES += OM2P
+
endif # ifeq ($(SUBTARGET),generic)
ifeq ($(SUBTARGET),nand)
@@ -1209,6 +1215,15 @@ endif
$(call Image/Build/Profile/$(if $(CONFIG_IB),Default,$(IMAGE_PROFILE)),loader)
endef
+define Image/Prepare/Profile
+ $(call Image/Build/Profile/$(1),loader)
+endef
+
+define Image/Build/Profile
+ $(call Image/Build/Profile/$(1),buildkernel)
+ $(call Image/Build/Profile/$(1),$(2))
+endef
+
# $(1): filesystem type.
define Image/Build
$(call Image/Build/$(call rootfs_type,$(1)),$(1))