summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2014-01-23 12:23:10 +0000
committerGabor Juhos <juhosg@openwrt.org>2014-01-23 12:23:10 +0000
commit447530995a3a30685670ee56e7b18f2d3c6c383b (patch)
tree222087a65792cd28d9a87aeb608cfb5fd58a91df /target/linux/ar71xx/image
parentb629009eaa3e6bb877ac2d097c0529d2323bad3a (diff)
downloadmaster-31e0f0ae-447530995a3a30685670ee56e7b18f2d3c6c383b.tar.gz
master-31e0f0ae-447530995a3a30685670ee56e7b18f2d3c6c383b.tar.bz2
master-31e0f0ae-447530995a3a30685670ee56e7b18f2d3c6c383b.zip
ar71xx: add initramfs image support for Compex devices
Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 39375
Diffstat (limited to 'target/linux/ar71xx/image')
-rw-r--r--target/linux/ar71xx/image/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 9be9bd025f..e9ffd77d9c 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -66,6 +66,16 @@ define CompressLzma
$(STAGING_DIR_HOST)/bin/lzma e $(1) -lc1 -lp2 -pb2 $(3) $(2)
endef
+define PatchKernel
+ cp $(KDIR)/vmlinux$(3) $(KDIR_TMP)/vmlinux$(3)-$(1)
+ $(STAGING_DIR_HOST)/bin/patch-cmdline $(KDIR_TMP)/vmlinux$(3)-$(1) "$(strip $(2))"
+endef
+
+define PatchKernel/initramfs
+ $(call PatchKernel,$(1),$(2),-initramfs)
+ cp $(KDIR_TMP)/vmlinux-initramfs-$(1) $(call imgname,initramfs,$(1)).bin
+endef
+
define PatchKernelLzma
cp $(KDIR)/vmlinux$(4) $(KDIR_TMP)/vmlinux$(4)-$(1)
$(STAGING_DIR_HOST)/bin/patch-cmdline $(KDIR_TMP)/vmlinux$(4)-$(1) "$(strip $(2))"
@@ -427,6 +437,7 @@ endef
Image/Build/MyLoader/buildkernel=$(call PatchKernelLzma,$(2),$(3))
+Image/Build/MyLoader/initramfs=$(call PatchKernel/initramfs,$(2),$(3))
define Image/Build/MyLoader
-$(STAGING_DIR_HOST)/bin/mkmylofw -B $(2) -s $(4) \