summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2014-01-24 17:15:03 +0000
committerGabor Juhos <juhosg@openwrt.org>2014-01-24 17:15:03 +0000
commit09bf46d4189531cb530ad6514e795c30012bcd1a (patch)
tree675883798b113c6aed917eda4ca98de42e89c032 /target/linux/ar71xx/image
parent252e906ddac3af4f50ee130bdc82363d55a8ff43 (diff)
downloadmaster-31e0f0ae-09bf46d4189531cb530ad6514e795c30012bcd1a.tar.gz
master-31e0f0ae-09bf46d4189531cb530ad6514e795c30012bcd1a.tar.bz2
master-31e0f0ae-09bf46d4189531cb530ad6514e795c30012bcd1a.zip
ar71xx: image: generate sysupgrade images for the Compex boards
Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 39391
Diffstat (limited to 'target/linux/ar71xx/image')
-rw-r--r--target/linux/ar71xx/image/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 5fe8ae4cbe..9cd9c26c36 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -457,11 +457,13 @@ define Image/Build/MyLoader
$(eval fwimage=$(KDIR_TMP)/$(2)-$(5)-firmware.bin)
$(call CatFiles,$(KDIR_TMP)/vmlinux-$(2).bin.lzma,65536,$(KDIR)/root.$(1),$(fwsize),$(fwimage))
if [ -e "$(fwimage)" ]; then \
- cp $(fwimage) $(call imgname,$(1),$(2))-$(5)-sysupgrade.bin; \
$(STAGING_DIR_HOST)/bin/mkmylofw -B $(2) -s $(4) -v \
-p0x00030000:0:al:0x80060000:firmware:$(fwimage) \
$(call imgname,$(1),$(2))-$(5)-factory.img; \
- true; \
+ echo -n "" > $(KDIR_TMP)/empty.bin; \
+ sh $(TOPDIR)/scripts/combined-image.sh \
+ $(fwimage) $(KDIR_TMP)/empty.bin \
+ $(call imgname,$(1),$(2))-$(5)-sysupgrade.bin; \
fi
endef