summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image/legacy-devices.mk
diff options
context:
space:
mode:
authorYousong Zhou <yszhou4tech@gmail.com>2016-06-30 09:54:21 +0800
committerJohn Crispin <john@phrozen.org>2016-06-30 22:48:39 +0200
commit559a7d1177fcbb4e276f864f465fce9297624eaf (patch)
treeffb1a0ee7c988c154f511c8e758cc3c41e03ab2b /target/linux/ar71xx/image/legacy-devices.mk
parentea284d704b34fd6222693be1382b31b5fd03b157 (diff)
downloadmaster-31e0f0ae-559a7d1177fcbb4e276f864f465fce9297624eaf.tar.gz
master-31e0f0ae-559a7d1177fcbb4e276f864f465fce9297624eaf.tar.bz2
master-31e0f0ae-559a7d1177fcbb4e276f864f465fce9297624eaf.zip
ar71xx: seama: fix making factory images
rootfs part needs to be aligned to erase block size which is passed as the 6th argument to Image/Build/Seama and is now 65536 since commit commit 5119ee9 "ar71xx: fix bogus hardcoded kernel image size for Seama images (fixes #20585)", but $(($(6) - 64)) still assumes that the argument is a limit on kernel partition size, i.e. 1310720, so the generated factory image is wrong in that the kernel will fail to find the rootfs (FlySpray link at [1]) This patch will workaround it with the following steps 1. Calculate the required space for seama header and META data in step 5 2. Pre-padding 64 bytes to lzma-compressed loader 3. Generate correctly padded image-$(2).tmp 4. Strip out the padding 5. Seal it with seama utility While at it convert seama to new build method [1] FS#35 - mynet-n750 factory images don't find root partition, https://bugs.lede-project.org/index.php?do=details&task_id=35 Reported-by: Steven Haigh <netwiz@crc.id.au> Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
Diffstat (limited to 'target/linux/ar71xx/image/legacy-devices.mk')
-rw-r--r--target/linux/ar71xx/image/legacy-devices.mk18
1 files changed, 0 insertions, 18 deletions
diff --git a/target/linux/ar71xx/image/legacy-devices.mk b/target/linux/ar71xx/image/legacy-devices.mk
index c8e14769b4..07d3df6831 100644
--- a/target/linux/ar71xx/image/legacy-devices.mk
+++ b/target/linux/ar71xx/image/legacy-devices.mk
@@ -542,12 +542,6 @@ define LegacyDevice/MZKW300NH
endef
LEGACY_DEVICES += MZKW300NH
-define LegacyDevice/QIHOO360
- DEVICE_TITLE := Qihoo 360 C301
- DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev kmod-ath10k
-endef
-LEGACY_DEVICES += QIHOO360
-
define LegacyDevice/RW2458N
DEVICE_TITLE := Redwave RW2458N
DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-ath9k wpad-mini
@@ -608,18 +602,6 @@ define LegacyDevice/DR344
endef
LEGACY_DEVICES += DR344
-define LegacyDevice/MYNETN600
- DEVICE_TITLE := WD My Net N600
- DEVICE_PACKAGES := kmod-usb-core kmod-usb2
-endef
-LEGACY_DEVICES += MYNETN600
-
-define LegacyDevice/MYNETN750
- DEVICE_TITLE := WD My Net N750
- DEVICE_PACKAGES := kmod-usb-core kmod-usb2
-endef
-LEGACY_DEVICES += MYNETN750
-
define LegacyDevice/MYNETREXT
DEVICE_TITLE := WD My Net Wi-Fi Range Extender
DEVICE_PACKAGES := rssileds