summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image/Makefile
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-08-02 09:54:33 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-08-02 09:54:33 +0000
commite29d6bec6f012ccd39872bd65ecec6407630379e (patch)
treed7857411fdda7ab4e1f86a8706a6a28090913864 /target/linux/ar71xx/image/Makefile
parent79a8660d679b711598794dfab9f1bebe390dfac4 (diff)
downloadmaster-31e0f0ae-e29d6bec6f012ccd39872bd65ecec6407630379e.tar.gz
master-31e0f0ae-e29d6bec6f012ccd39872bd65ecec6407630379e.tar.bz2
master-31e0f0ae-e29d6bec6f012ccd39872bd65ecec6407630379e.zip
ar71xx: image: allow to use board specific code in the lzma-loader
SVN-Revision: 32945
Diffstat (limited to 'target/linux/ar71xx/image/Makefile')
-rw-r--r--target/linux/ar71xx/image/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 3897dd49bf..26ac0ab102 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -113,7 +113,7 @@ define Image/BuildLoader
-rm -rf $(KDIR)/lzma-loader
$(LOADER_MAKE) LOADER=loader-$(1).$(2) KERNEL_CMDLINE="$(3)"\
LZMA_TEXT_START=0x80a00000 LOADADDR=0x80060000 \
- LOADER_DATA="$(KDIR)/vmlinux.bin.lzma" \
+ LOADER_DATA="$(KDIR)/vmlinux.bin.lzma" BOARD="$(1)" \
compile loader.$(2)
endef
@@ -121,7 +121,7 @@ define Image/BuildLoaderAlone
-rm -rf $(KDIR)/lzma-loader
$(LOADER_MAKE) LOADER=loader-$(1).$(2) KERNEL_CMDLINE="$(3)" \
LZMA_TEXT_START=0x80a00000 LOADADDR=0x80060000 \
- FLASH_OFFS=$(4) FLASH_MAX=$(5) \
+ BOARD="$(1)" FLASH_OFFS=$(4) FLASH_MAX=$(5) \
compile loader.$(2)
endef