summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-12-19 11:27:39 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-12-19 11:27:39 +0000
commitbee52ee5799c072fdd14becc80844ce144831fef (patch)
tree51821604c2894f1254c692ea1eff216447d63606 /target/linux/ar71xx/image/Makefile
parent3f184882e8427f2e0bd06c3b5c43dfdf22219ca0 (diff)
downloadmaster-31e0f0ae-bee52ee5799c072fdd14becc80844ce144831fef.tar.gz
master-31e0f0ae-bee52ee5799c072fdd14becc80844ce144831fef.tar.bz2
master-31e0f0ae-bee52ee5799c072fdd14becc80844ce144831fef.zip
ar71xx: PowerCloud CAP324 image generation
Image generation (and mtd partition) part of support for PowerCloud CAP324 Cloud AP. The CAP324 Cloud AP is a device sold by PowerCloud Systems who's stock firmware (CloudCommand) provides 'cloud' based managment of large numbers of access points. The CAP324 is a dual-band 802.11n wireless access point with 16MB flash and 128MB RAM and single gigabit ethernet port. It can be powered via PoE or a power adaptor. Signed-off-by: Daniel Dickinson <openwrt@daniel.thecshore.com> SVN-Revision: 47941
Diffstat (limited to 'target/linux/ar71xx/image/Makefile')
-rw-r--r--target/linux/ar71xx/image/Makefile18
1 files changed, 18 insertions, 0 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 10de2237d5..5783221b1d 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -392,6 +392,24 @@ define Device/tl-wdr7500-v3
endef
TARGET_DEVICES += archer-c5-v1 archer-c7-v1 archer-c7-v2 tl-wdr7500-v3
+define Device/cap324
+ BOARDNAME := CAP324
+ DEVICE_PROFILE := CAP324
+ IMAGE_SIZE = 15296k
+ MTDPARTS = spi0.0:256k(u-boot),64k(u-boot-env)ro,15296k(firmware),640k(certs),64k(nvram),64k(art)
+endef
+
+TARGET_DEVICES += cap324
+
+define Device/cap324-nocloud
+ BOARDNAME := CAP324
+ DEVICE_PROFILE := CAP324
+ IMAGE_SIZE = 16000k
+ MTDPARTS = spi0.0:256k(u-boot),64k(u-boot-env)ro,16000k(firmware),64k(art)
+endef
+
+TARGET_DEVICES += cap324-nocloud
+
define Device/antminer-s1
$(Device/tplink-8mlzma)
BOARDNAME := ANTMINER-S1