summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-12-19 11:27:52 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-12-19 11:27:52 +0000
commit4c282ecfe855145fa0b3ba1d2898042e0e4d2e3f (patch)
treeefa20c2df1cb6ddc0879c3158f0a10f97e6587e9 /target/linux/ar71xx/image/Makefile
parent09a97f42d95bb97bc24328c21882eb569d7ac8df (diff)
downloadmaster-31e0f0ae-4c282ecfe855145fa0b3ba1d2898042e0e4d2e3f.tar.gz
master-31e0f0ae-4c282ecfe855145fa0b3ba1d2898042e0e4d2e3f.tar.bz2
master-31e0f0ae-4c282ecfe855145fa0b3ba1d2898042e0e4d2e3f.zip
ar71xx: Image generation for PowerCloud CR5000 Cloud Router
Kernel part of support for the PowerCloud Systems CR5000. The CR5000 is a dual-band 802.11n wireless router with 8MB flash, 64 MB RAM, (unused in stock firmware) USB 2.0 port, and five port gigabit ethernet switch. The CR5000 was sold as hardware for the Skydog cloud-managed router service. Signed-off-by: Daniel Dickinson <openwrt@daniel.thecshore.com> SVN-Revision: 47943
Diffstat (limited to 'target/linux/ar71xx/image/Makefile')
-rw-r--r--target/linux/ar71xx/image/Makefile18
1 files changed, 18 insertions, 0 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index af9516eaa7..61c76a342b 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -427,6 +427,24 @@ endef
TARGET_DEVICES += cr3000-nocloud
+define Device/cr5000
+ BOARDNAME := CR5000
+ DEVICE_PROFILE := CR5000
+ IMAGE_SIZE = 7104k
+ MTDPARTS = spi0.0:256k(u-boot),64k(u-boot-env)ro,7104k(firmware),640k(certs),64k(nvram),64k(art)
+endef
+
+TARGET_DEVICES += cr5000
+
+define Device/cr5000-nocloud
+ BOARDNAME := CR5000
+ DEVICE_PROFILE := CR5000
+ IMAGE_SIZE = 7808k
+ MTDPARTS = spi0.0:256k(u-boot),64k(u-boot-env)ro,7808k(firmware),64k(art)
+endef
+
+TARGET_DEVICES += cr5000-nocloud
+
define Device/antminer-s1
$(Device/tplink-8mlzma)
BOARDNAME := ANTMINER-S1