summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image/Makefile
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2009-11-25 09:51:31 +0000
committerGabor Juhos <juhosg@openwrt.org>2009-11-25 09:51:31 +0000
commit4704478682957b9671bd4408eda14e651320113c (patch)
tree1fd72517a0684d39c6a0bc90d90341bdd3c600c0 /target/linux/ar71xx/image/Makefile
parentbc97b5de8b24f6eb56fe956b50237280d3c75a8d (diff)
downloadmaster-31e0f0ae-4704478682957b9671bd4408eda14e651320113c.tar.gz
master-31e0f0ae-4704478682957b9671bd4408eda14e651320113c.tar.bz2
master-31e0f0ae-4704478682957b9671bd4408eda14e651320113c.zip
ar71xx: add sysupgrade support for Ubiquiti XM boards
SVN-Revision: 18533
Diffstat (limited to 'target/linux/ar71xx/image/Makefile')
-rw-r--r--target/linux/ar71xx/image/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 30663f12cb..b61524ecdb 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -138,7 +138,7 @@ define Image/Build/MyLoader
$(call imgname,$(1),$(2))-16M.img
endef
-ubntxm_mtdlayout=mtdparts=spi0.0:256k(u-boot),64k(u-boot-env),1024k(kernel),6528k(rootfs),256k(cfg),64k(EEPROM)
+ubntxm_mtdlayout=mtdparts=spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,1024k(kernel),6528k(rootfs),256k(cfg)ro,64k(EEPROM)ro,7552k@0x50000(firmware)
define Image/Build/UBNTXM
$(call PatchKernelLzma,$(2),$(3) $(ubntxm_mtdlayout))
mkimage -A mips -O linux -T kernel -a 0x80060000 -C lzma -e \
@@ -151,7 +151,11 @@ define Image/Build/UBNTXM
-B $(4) -v $(5).$(6).OpenWrt.$(REVISION) \
-k $(KDIR)/vmlinux-$(2).uImage \
-r $(BIN_DIR)/openwrt-$(BOARD)-root.$(1) \
- -o $(call imgname,$(1),$(2)).bin
+ -o $(call imgname,$(1),$(2))-factory.bin
+ ( \
+ dd if=$(KDIR)/vmlinux-$(2).uImage; \
+ dd if=$(BIN_DIR)/openwrt-$(BOARD)-root.$(1); \
+ ) > $(call imgname,$(1),$(2))-sysupgrade.bin
endef
define Image/Build/UBNT