summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2010-01-18 00:12:15 +0000
committerFelix Fietkau <nbd@openwrt.org>2010-01-18 00:12:15 +0000
commit2670e906b6f9c500b87ece595825e88aa5157ff4 (patch)
treeb219c48d4125fa9e278111471ba9594c4714f740 /target/linux/ar71xx/image/Makefile
parent88ddc596556bad277edd5466cdb71f3981597666 (diff)
downloadmaster-31e0f0ae-2670e906b6f9c500b87ece595825e88aa5157ff4.tar.gz
master-31e0f0ae-2670e906b6f9c500b87ece595825e88aa5157ff4.tar.bz2
master-31e0f0ae-2670e906b6f9c500b87ece595825e88aa5157ff4.zip
ar71xx: fix portability errors in dd commands
SVN-Revision: 19207
Diffstat (limited to 'target/linux/ar71xx/image/Makefile')
-rw-r--r--target/linux/ar71xx/image/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 96611bb470..d3baec69e1 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -126,7 +126,7 @@ define Image/Build/WZRHPG300NH
-n 'MIPS OpenWrt Linux-$(LINUX_VERSION)' \
-d $(KDIR)/vmlinux-$(2).bin.lzma $(KDIR)/vmlinux-$(2).uImage; \
( \
- dd if=$(KDIR)/vmlinux-$(2).uImage bs=1M conv=sync; \
+ dd if=$(KDIR)/vmlinux-$(2).uImage bs=1024k conv=sync; \
dd if=$(KDIR)/root.$(1) bs=128k conv=sync; \
) > $(call imgname,$(1),$(2))-sysupgrade.bin; \
fi; fi
@@ -305,7 +305,7 @@ define Image/Build/WNDR3700
$(KDIR)/vmlinux-$(2).uImage.squashfs
-rm -f $(KDIR)/vmlinux-$(2).uImage.squashfs.tmp*
( \
- dd if=$(KDIR)/vmlinux-$(2).uImage.squashfs bs=1M conv=sync; \
+ dd if=$(KDIR)/vmlinux-$(2).uImage.squashfs bs=1024k conv=sync; \
dd if=$(KDIR)/root.$(1) bs=64k; \
) > $(call imgname,$(1),$(2))-sysupgrade.bin
$(STAGING_DIR_HOST)/bin/mkdniimg \