summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/generic
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2015-11-10 23:13:09 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2015-11-10 23:13:09 +0000
commitfa137d51f5cbc678922950a6b06883c1d2141ac2 (patch)
tree410f5ff10ecb345af68628cf3e09703b624ea41e /target/linux/ar71xx/generic
parent1bfbf2de6df94a5e62f690bec9999702e3ad4c81 (diff)
downloadmaster-31e0f0ae-fa137d51f5cbc678922950a6b06883c1d2141ac2.tar.gz
master-31e0f0ae-fa137d51f5cbc678922950a6b06883c1d2141ac2.tar.bz2
master-31e0f0ae-fa137d51f5cbc678922950a6b06883c1d2141ac2.zip
ar71xx: add Arduino Yun
This is based on patches from Federico Fissore <f.fissore@arduino.cc> especially this one: https://github.com/arduino/openwrt-yun/commit/7e2976fa83fb0d72a955574499178c387a1b3c92 The console is running with 250000 baud which is a non standard baud rate and needs an extra patch to be applied, I will try to get this patch upstream or something else which accomplish the same. Some upstream code looks like there are many different versions of this SoC, are these only internal versions and all versions on the consumer market are the same? I saw different GPIO configuration and flash sizes of 8MB and 16MB? Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de> SVN-Revision: 47451
Diffstat (limited to 'target/linux/ar71xx/generic')
-rw-r--r--target/linux/ar71xx/generic/profiles/arduino.mk19
1 files changed, 19 insertions, 0 deletions
diff --git a/target/linux/ar71xx/generic/profiles/arduino.mk b/target/linux/ar71xx/generic/profiles/arduino.mk
new file mode 100644
index 0000000000..8ae5054a7e
--- /dev/null
+++ b/target/linux/ar71xx/generic/profiles/arduino.mk
@@ -0,0 +1,19 @@
+#
+# Copyright (C) 2009-2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Yun
+ NAME:=Arduino Yun based on Atheros AR9331
+ PACKAGES:=kmod-usb-core kmod-usb2
+endef
+
+define Profile/Yun/Description
+ Package set optimized for the Arduino Yun.
+ This is sometimes also named Genuino Yun or Linino Yun.
+endef
+
+$(eval $(call Profile,Yun))
+