summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/generic
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-07-26 07:32:01 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-07-26 07:32:01 +0000
commitf093cda481127f5c3891ddbcf3995b3884f37e7b (patch)
tree3c9361b7a61cd34e57e46a28b130b74bb6248f57 /target/linux/ar71xx/generic
parent2fb993fdbfb61f53c6444bc6cb7fc61dfcd20d09 (diff)
downloadmaster-31e0f0ae-f093cda481127f5c3891ddbcf3995b3884f37e7b.tar.gz
master-31e0f0ae-f093cda481127f5c3891ddbcf3995b3884f37e7b.tar.bz2
master-31e0f0ae-f093cda481127f5c3891ddbcf3995b3884f37e7b.zip
ar71xx: add profile and fixup image generation for the TL-MR10U board
Create a separate board profile and update the profile name in image/makefile. Also use the correct machtype string in kernel command line. Based on andelf's patch: http://andelf.diandian.com/post/2013-05-22/40050677370 Signed-off-by: Oleg Titov <oleg.titov@gmail.com> Patchwork: http://patchwork.openwrt.org/patch/3840/ Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 37550
Diffstat (limited to 'target/linux/ar71xx/generic')
-rw-r--r--target/linux/ar71xx/generic/profiles/tp-link.mk11
1 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/ar71xx/generic/profiles/tp-link.mk b/target/linux/ar71xx/generic/profiles/tp-link.mk
index 8c16df6a55..30e2b9cf2e 100644
--- a/target/linux/ar71xx/generic/profiles/tp-link.mk
+++ b/target/linux/ar71xx/generic/profiles/tp-link.mk
@@ -16,6 +16,17 @@ endef
$(eval $(call Profile,ARCHERC7))
+define Profile/TLMR10U
+ NAME:=TP-LINK TL-MR10U
+ PACKAGES:=kmod-usb-core kmod-usb2
+endef
+
+define Profile/TLMR10U/Description
+ Package set optimized for the TP-LINK TL-MR10U.
+endef
+$(eval $(call Profile,TLMR10U))
+
+
define Profile/TLMR11U
NAME:=TP-LINK TL-MR11U
PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev