summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/generic
diff options
context:
space:
mode:
authorAllan Nick Pedrana <nik9993@gmail.com>2016-05-29 17:26:03 -0500
committerJo-Philipp Wich <jo@mein.io>2016-06-07 11:21:55 +0200
commite61fe4e4d762eb3e00c43b6714a229835efc7ea5 (patch)
tree737e21a9790d68f2cc6a51d0bae1f90b96082b5f /target/linux/ar71xx/generic
parent69b45d2223e3069407be97fd7b76a14b8d195cee (diff)
downloadmaster-31e0f0ae-e61fe4e4d762eb3e00c43b6714a229835efc7ea5.tar.gz
master-31e0f0ae-e61fe4e4d762eb3e00c43b6714a229835efc7ea5.tar.bz2
master-31e0f0ae-e61fe4e4d762eb3e00c43b6714a229835efc7ea5.zip
ar71xx: add support for OpenEmbed SOM9331
This patch adds the target profile SOM9331 and configures hardware functionality for the 3x Eth Ports & corresponding LED's, the USB Host, the USART to USB bridge and the System LED. Signed-off-by: Allan Nick Pedrana <nik9993@gmail.com>
Diffstat (limited to 'target/linux/ar71xx/generic')
-rw-r--r--target/linux/ar71xx/generic/profiles/openembed.mk13
1 files changed, 13 insertions, 0 deletions
diff --git a/target/linux/ar71xx/generic/profiles/openembed.mk b/target/linux/ar71xx/generic/profiles/openembed.mk
new file mode 100644
index 0000000000..2603e0a4cb
--- /dev/null
+++ b/target/linux/ar71xx/generic/profiles/openembed.mk
@@ -0,0 +1,13 @@
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+
+define Profile/SOM9331
+ NAME:=OpenEmbed SOM9331
+ PACKAGES:=kmod-usb-core kmod-usb2 kmod-usb-storage kmod-i2c-core kmod-i2c-gpio-custom kmod-spi-bitbang kmod-spi-dev kmod-spi-gpio kmod-spi-gpio-custom kmod-usb-serial
+endef
+
+define Profile/SOM9331/Description
+ Package set optimized for the OpenEmbed SOM9331.
+endef
+$(eval $(call Profile,SOM9331))
+