summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/generic
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-08-17 06:24:04 +0000
committerJohn Crispin <john@openwrt.org>2015-08-17 06:24:04 +0000
commitaf60c367b7a16d80dba422b00fde2611a7c7d2ca (patch)
treeeca3466e8014f320c43aed0484a5cf2e37c0e1dc /target/linux/ar71xx/generic
parenta2b38ebf77844460eaf8f4c2496af505e001b49d (diff)
downloadmaster-31e0f0ae-af60c367b7a16d80dba422b00fde2611a7c7d2ca.tar.gz
master-31e0f0ae-af60c367b7a16d80dba422b00fde2611a7c7d2ca.tar.bz2
master-31e0f0ae-af60c367b7a16d80dba422b00fde2611a7c7d2ca.zip
ar71xx: add support for TP-Link TL-WDR6500 v2
Signed-off-by: Weijie Gao <hackpascal@gmail.com> This patch adds support for TP-Link TL-WDR6500 v2. The firmware has a U-Boot header for kernel, and a TP-LINK v2 header for the whole firmware, so I have to create a new firmware creation method. SVN-Revision: 46663
Diffstat (limited to 'target/linux/ar71xx/generic')
-rw-r--r--target/linux/ar71xx/generic/profiles/tp-link.mk11
1 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/ar71xx/generic/profiles/tp-link.mk b/target/linux/ar71xx/generic/profiles/tp-link.mk
index 0174a431b1..05d10196d3 100644
--- a/target/linux/ar71xx/generic/profiles/tp-link.mk
+++ b/target/linux/ar71xx/generic/profiles/tp-link.mk
@@ -277,6 +277,17 @@ endef
$(eval $(call Profile,TLWDR4900V2))
+define Profile/TLWDR6500V2
+ NAME:=TP-LINK TL-WDR6500v2
+ PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev kmod-ath10k
+endef
+
+define Profile/TLWDR6500V2/Description
+ Package set optimized for the TP-LINK TL-WDR6500v2.
+endef
+$(eval $(call Profile,TLWDR6500V2))
+
+
define Profile/TLWR740
NAME:=TP-LINK TL-WR740N/ND
PACKAGES:=