summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/generic
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-10-19 17:55:25 +0000
committerJohn Crispin <john@openwrt.org>2015-10-19 17:55:25 +0000
commit8d8a937272fd03902d4e40888efcf3ff707c0d57 (patch)
treec4f6626928a3dad1d94cc2e9f4ab9ef77429d453 /target/linux/ar71xx/generic
parent795cc23a08b7e70743a125bc4f9c2fa7d284a26c (diff)
downloadmaster-31e0f0ae-8d8a937272fd03902d4e40888efcf3ff707c0d57.tar.gz
master-31e0f0ae-8d8a937272fd03902d4e40888efcf3ff707c0d57.tar.bz2
master-31e0f0ae-8d8a937272fd03902d4e40888efcf3ff707c0d57.zip
ar71xx: Add Gainstrong MiniBox v1.0 support to trunk
This patch supersedes the v1 from September 17th. Bumping the patch version - the MiniBox profile showed up under M, but since it's called 'Gainstrong MiniBox v1.0' now it looks out of place. Renamed the profile to gs-minibox-v1.mk to fix that. The following patch adds support for the Gainstrong MiniBox into trunk (or 'Designated Driver' :D ). Fixed items: - Inverted LED polarity (OOLITE seems to suffer from the same problem). - Changed uppercase MINIBOX_V1_ prefix as requested. - Prefixes are now gs_minibox_ similar to gs_oolite_ (same vendor). - Mention the vendor (Gainstrong) in code headers. Compiles fine, has been confirmed working by owners on 15.05. Question: I've seen some boards use tools/firmware-utils/src/mktplinkfw.c, the MiniBox images build fine without, so I'm wondering: do I need to add it in there as well? Any added benefit? Thank you Signed-off by: Stijn Segers <francesco.borromini@inventati.org> SVN-Revision: 47234
Diffstat (limited to 'target/linux/ar71xx/generic')
-rw-r--r--target/linux/ar71xx/generic/profiles/gs-minibox-v1.mk17
1 files changed, 17 insertions, 0 deletions
diff --git a/target/linux/ar71xx/generic/profiles/gs-minibox-v1.mk b/target/linux/ar71xx/generic/profiles/gs-minibox-v1.mk
new file mode 100644
index 0000000000..1484114230
--- /dev/null
+++ b/target/linux/ar71xx/generic/profiles/gs-minibox-v1.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/MINIBOXV1
+ NAME:=Gainstrong MiniBox V1.0
+ PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
+endef
+
+
+define Profile/MINIBOXV1/Description
+ Package set optimized for the Gainstrong MiniBox V1.0
+endef
+$(eval $(call Profile,MINIBOXV1))