summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/generic
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2013-08-15 00:57:47 +0000
committerLuka Perkov <luka@openwrt.org>2013-08-15 00:57:47 +0000
commit5064c81457129bf430db18f372199f6e9892b524 (patch)
treef6e700c067011bc8e802f3cb3a580357934b4538 /target/linux/ar71xx/generic
parentc67640bbd4bde8ae7474dc6b2780ced7ee2b4fc0 (diff)
downloadmaster-31e0f0ae-5064c81457129bf430db18f372199f6e9892b524.tar.gz
master-31e0f0ae-5064c81457129bf430db18f372199f6e9892b524.tar.bz2
master-31e0f0ae-5064c81457129bf430db18f372199f6e9892b524.zip
ar71xx: add support for hornet-ub-x2
The hornet-ub-x2 is hornet-ub variant with double more flash and ram. Signed-off-by: Luka Perkov <luka@openwrt.org> SVN-Revision: 37788
Diffstat (limited to 'target/linux/ar71xx/generic')
-rw-r--r--target/linux/ar71xx/generic/profiles/alfa.mk23
1 files changed, 18 insertions, 5 deletions
diff --git a/target/linux/ar71xx/generic/profiles/alfa.mk b/target/linux/ar71xx/generic/profiles/alfa.mk
index 06baf240c2..97c843ace1 100644
--- a/target/linux/ar71xx/generic/profiles/alfa.mk
+++ b/target/linux/ar71xx/generic/profiles/alfa.mk
@@ -1,12 +1,12 @@
#
-# Copyright (C) 2011 OpenWrt.org
+# Copyright (C) 2011-2013 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
define Profile/ALFAAP96
- NAME:=ALFA Network AP96 board
+ NAME:=ALFA Network AP96 board
PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-rtc-pcf2123
endef
@@ -18,17 +18,31 @@ $(eval $(call Profile,ALFAAP96))
define Profile/HORNETUB
- NAME:=ALFA Network Hornet-UB board
+ NAME:=ALFA Network Hornet-UB board (8MB flash, 32MB ram)
PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
endef
define Profile/HORNETUB/Description
- Package set optimized for the ALFA Network Hornet-UB board.
+ Package set optimized for the ALFA Network Hornet-UB board with 8MB
+ flash and 32MB ram.
endef
$(eval $(call Profile,HORNETUB))
+define Profile/HORNETUBx2
+ NAME:=ALFA Network Hornet-UB-x2 board (16MB flash, 64MB ram)
+ PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
+endef
+
+define Profile/HORNETUBx2/Description
+ Package set optimized for the ALFA Network Hornet-UB board with 16MB
+ flash and 64MB ram.
+endef
+
+$(eval $(call Profile,HORNETUBx2))
+
+
define Profile/ALFANX
NAME:=ALFA Network N2/N5 board
PACKAGES:=
@@ -39,4 +53,3 @@ define Profile/ALFANX/Description
endef
$(eval $(call Profile,ALFANX))
-