summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/generic
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-09-11 16:31:35 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-09-11 16:31:35 +0000
commit2ce833060a6ac412d0df362edb950b19da9af04c (patch)
tree2efca0bea4ee276b1e938100441743007f0a4c6a /target/linux/ar71xx/generic
parent3adce75a67ba10fc151fe49d4dad3f04fe265135 (diff)
downloadmaster-31e0f0ae-2ce833060a6ac412d0df362edb950b19da9af04c.tar.gz
master-31e0f0ae-2ce833060a6ac412d0df362edb950b19da9af04c.tar.bz2
master-31e0f0ae-2ce833060a6ac412d0df362edb950b19da9af04c.zip
target: ar71xx: add support for COMFAST CF-E316N v2 board
This adds full support (sans sysupgrading from vendor firmware) for the COMFAST CF-E316N v2 (aka CF-E316V2, CF-E316N-V2 and CF-E316Nv2.0, no FCC ID) by Shenzhen Four Seas Global Link Network Technology Co., Ltd (this company is actively refusing to provide GPL'd sources for the OpenWrt version they ship with the device, damn them). Signed-off-by: Paul Fertser <fercerpav@gmail.com> SVN-Revision: 46852
Diffstat (limited to 'target/linux/ar71xx/generic')
-rw-r--r--target/linux/ar71xx/generic/profiles/comfast.mk19
1 files changed, 19 insertions, 0 deletions
diff --git a/target/linux/ar71xx/generic/profiles/comfast.mk b/target/linux/ar71xx/generic/profiles/comfast.mk
new file mode 100644
index 0000000000..5d447e5cec
--- /dev/null
+++ b/target/linux/ar71xx/generic/profiles/comfast.mk
@@ -0,0 +1,19 @@
+#
+# Copyright (C) 2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/CF-E316N-V2
+ NAME:=COMFAST CF-E316N v2
+ PACKAGES:=
+endef
+
+define Profile/CF-E316N-V2/Description
+ Package set optimised for the COMFAST CF-E316N v2
+ by Shenzhen Four Seas Global Link Network Technology Co., Ltd
+ aka CF-E316V2, CF-E316N-V2 and CF-E316Nv2.0 (no FCC ID)
+endef
+
+$(eval $(call Profile,CF-E316N-V2))