summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/generic/profiles
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2010-09-27 08:59:53 +0000
committerFelix Fietkau <nbd@openwrt.org>2010-09-27 08:59:53 +0000
commita7bb7dd99ebe9fcdcc6fb3152eaa830a302d5028 (patch)
treebf3766d8eb911b06f2fdd299ff90dfece2bfafe1 /target/linux/ar71xx/generic/profiles
parenta41b1df07b7f8fb6500647c5934e394dd1628ea5 (diff)
downloadmaster-31e0f0ae-a7bb7dd99ebe9fcdcc6fb3152eaa830a302d5028.tar.gz
master-31e0f0ae-a7bb7dd99ebe9fcdcc6fb3152eaa830a302d5028.tar.bz2
master-31e0f0ae-a7bb7dd99ebe9fcdcc6fb3152eaa830a302d5028.zip
Add support for Atheros AP96 reference board
This is still preliminary and not really tested much. Anyway, this version seems to be enough to get both wired and wireless interfaces working. Buttons and leds are also working. mach-ap96.c is based on mach-wndr3700.c. Signed-off-by: Jouni Malinen <jouni.malinen@atheros.com> SVN-Revision: 23125
Diffstat (limited to 'target/linux/ar71xx/generic/profiles')
-rw-r--r--target/linux/ar71xx/generic/profiles/atheros.mk11
1 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/ar71xx/generic/profiles/atheros.mk b/target/linux/ar71xx/generic/profiles/atheros.mk
index 4ce0e605c6..97d5032574 100644
--- a/target/linux/ar71xx/generic/profiles/atheros.mk
+++ b/target/linux/ar71xx/generic/profiles/atheros.mk
@@ -28,6 +28,17 @@ endef
$(eval $(call Profile,AP83))
+define Profile/AP96
+ NAME:=Atheros AP96 reference board
+ PACKAGES:=wpad-mini kmod-ath9k kmod-usb-core kmod-usb2
+endef
+
+define Profile/AP96/Description
+ Package set optimized for the Atheros AP96 reference board.
+endef
+
+$(eval $(call Profile,AP96))
+
define Profile/PB42
NAME:=Atheros PB42 reference board
PACKAGES:=wpad-mini kmod-ath9k kmod-usb-core kmod-usb-ohci kmod-usb2