summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/generic/profiles
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-11-13 20:57:15 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-11-13 20:57:15 +0000
commit7ab0e1566fc30e716bd13589100b41f717952547 (patch)
tree84a795937e160b343539bf814633ebc3d38b28ee /target/linux/ar71xx/generic/profiles
parentf6c3a8ddd6c8451575dc8c4eba7e5e05c7dec8ad (diff)
downloadmaster-31e0f0ae-7ab0e1566fc30e716bd13589100b41f717952547.tar.gz
master-31e0f0ae-7ab0e1566fc30e716bd13589100b41f717952547.tar.bz2
master-31e0f0ae-7ab0e1566fc30e716bd13589100b41f717952547.zip
ar71xx: add profiles and build images for old PowerCloud System devices
[juhosg: - use 'PowerCloud Systems' instead of 'PCS' in the profiles - sort SingleProfile instances in image/Makefile] Signed-off-by: Daniel Dickinson <daniel@powercloudsystems.com> Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 34195
Diffstat (limited to 'target/linux/ar71xx/generic/profiles')
-rw-r--r--target/linux/ar71xx/generic/profiles/pcs.mk29
1 files changed, 29 insertions, 0 deletions
diff --git a/target/linux/ar71xx/generic/profiles/pcs.mk b/target/linux/ar71xx/generic/profiles/pcs.mk
new file mode 100644
index 0000000000..1399ef4233
--- /dev/null
+++ b/target/linux/ar71xx/generic/profiles/pcs.mk
@@ -0,0 +1,29 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+# Copyright (C) 2012 PowerCloud Systems
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/UBDEV01
+ NAME:=PowerCloud Systems ubdev01 model
+ PACKAGES:=
+endef
+
+define Profile/UBDEV01/Description
+ Package set optimized for the PowerCloud Systems ubdev01 board.
+endef
+
+$(eval $(call Profile,UBDEV01))
+
+define Profile/DLRTDEV01
+ NAME:=PowerCloud Systems dlrtdev01 model
+ PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-ledtrig-usbdev
+endef
+
+define Profile/DLRTDEV01/Description
+ Package set optimized for the PowerCloud Systems dlrtdev01 board.
+endef
+
+$(eval $(call Profile,DLRTDEV01))