summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/generic/profiles/tp-link.mk
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-01-04 17:30:47 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-01-04 17:30:47 +0000
commit1045c83527d8c1b178321de104305c3a491ef923 (patch)
tree3c32d80dbf7bbfd64d18ba97c9d27514553dbcb0 /target/linux/ar71xx/generic/profiles/tp-link.mk
parent55e13f4e6a46b9b1ce753b269deec4b6322a679f (diff)
downloadmaster-31e0f0ae-1045c83527d8c1b178321de104305c3a491ef923.tar.gz
master-31e0f0ae-1045c83527d8c1b178321de104305c3a491ef923.tar.bz2
master-31e0f0ae-1045c83527d8c1b178321de104305c3a491ef923.zip
ar71xx: add support for TP-Link TL-MR3020
This patch adds support for the TP-Link device TL-MR3020 which is very similiar to the TL-WR703N. The TL-MR3020 uses 5 LEDs, 1 push button and a switch with 3 positions. Only four LEDs can be controlled via GPIO. The power LED is connected to the power supply. The WPS push button has been mapped to KEY_WPS_BUTTON. The two GPIO signals of the sliding switch have been mapped to BTN_0 and BTN_1. I have also setup a wiki page with details here: http://wiki.openwrt.org/toh/tp-link/tl-mr3020 USB is working and has been tested with USB mass storage and USB UMTS stick. Wifi also seems to work. Ethernet is working too. Signed-off-by: Christian Cier-Zniewski <c.cier@gmx.de> SVN-Revision: 29651
Diffstat (limited to 'target/linux/ar71xx/generic/profiles/tp-link.mk')
-rw-r--r--target/linux/ar71xx/generic/profiles/tp-link.mk12
1 files changed, 12 insertions, 0 deletions
diff --git a/target/linux/ar71xx/generic/profiles/tp-link.mk b/target/linux/ar71xx/generic/profiles/tp-link.mk
index 8e0fa29e4a..c9f0cacb1e 100644
--- a/target/linux/ar71xx/generic/profiles/tp-link.mk
+++ b/target/linux/ar71xx/generic/profiles/tp-link.mk
@@ -5,6 +5,17 @@
# See /LICENSE for more information.
#
+define Profile/TLMR3020
+ NAME:=TP-LINK TL-MR3020
+ PACKAGES:=kmod-usb-core kmod-usb2
+endef
+
+define Profile/TLMR3020/Description
+ Package set optimized for the TP-LINK TL-MR3020.
+endef
+$(eval $(call Profile,TLMR3020))
+
+
define Profile/TLMR3220
NAME:=TP-LINK TL-MR3220
PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
@@ -32,6 +43,7 @@ define Profile/TLWR703
PACKAGES:=kmod-usb-core kmod-usb2
endef
+
define Profile/TLWR703/Description
Package set optimized for the TP-LINK TL-WR703N.
endef