summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/generic/profiles/devolo-dlan.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2016-06-17 06:53:22 +0200
committerJo-Philipp Wich <jo@mein.io>2016-06-27 11:10:15 +0200
commit8d1218ca7370a84c886a63917ef857c92ab9f25f (patch)
tree7ef242271b390a72028771e96bf6a10b7a7d844a /target/linux/ar71xx/generic/profiles/devolo-dlan.mk
parentdc140e00a93d54370021f819fd986290e8237cbe (diff)
downloadmaster-31e0f0ae-8d1218ca7370a84c886a63917ef857c92ab9f25f.tar.gz
master-31e0f0ae-8d1218ca7370a84c886a63917ef857c92ab9f25f.tar.bz2
master-31e0f0ae-8d1218ca7370a84c886a63917ef857c92ab9f25f.zip
ar71xx: merge profiles into image building code
- Remove old style device profiles and convert them to device definitions within the image building code - Fix the legacy build macros for the changed eval depth in the legacy image build wrapper Signed-off-by: John Crispin <john@phrozen.org> Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'target/linux/ar71xx/generic/profiles/devolo-dlan.mk')
-rw-r--r--target/linux/ar71xx/generic/profiles/devolo-dlan.mk46
1 files changed, 0 insertions, 46 deletions
diff --git a/target/linux/ar71xx/generic/profiles/devolo-dlan.mk b/target/linux/ar71xx/generic/profiles/devolo-dlan.mk
deleted file mode 100644
index 44a6869f0e..0000000000
--- a/target/linux/ar71xx/generic/profiles/devolo-dlan.mk
+++ /dev/null
@@ -1,46 +0,0 @@
-#
-# Copyright (C) 2015 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/dLAN_Hotspot
- NAME:=devolo dLAN Hotspot
- PACKAGES:=open-plc-utils open-plc-utils-chkpib open-plc-utils-getpib open-plc-utils-modpib \
- open-plc-utils-setpib open-plc-utils-hpavkey open-plc-utils-plchost \
- open-plc-utils-plctool open-plc-utils-pibdump open-plc-utils-plcstat \
- ebtables hostapd-utils wifitoggle wpad
-endef
-
-define Profile/dLAN_Hotspot/Description
- Package set optimized for the devolo dLAN Hotspot.
-endef
-$(eval $(call Profile,dLAN_Hotspot))
-
-define Profile/dLAN_pro_500_wp
- NAME:=devolo dLAN pro 500 Wireless+
- PACKAGES:=open-plc-utils open-plc-utils-chkpib open-plc-utils-getpib open-plc-utils-modpib \
- open-plc-utils-setpib open-plc-utils-hpavkey open-plc-utils-amphost \
- open-plc-utils-plctool open-plc-utils-pibdump open-plc-utils-plcstat \
- ebtables hostapd-utils wifitoggle wpad
-endef
-
-define Profile/dLAN_pro_500_wp/Description
- Package set optimized for the devolo dLAN pro 500 Wireless+.
-endef
-$(eval $(call Profile,dLAN_pro_500_wp))
-
-define Profile/dLAN_pro_1200_ac
- NAME:=devolo dLAN pro 1200+ WiFi ac
- PACKAGES:=open-plc-utils open-plc-utils-chkpib open-plc-utils-getpib open-plc-utils-modpib \
- open-plc-utils-setpib open-plc-utils-hpavkey open-plc-utils-plchost \
- open-plc-utils-plctool open-plc-utils-pibdump open-plc-utils-plcstat \
- ebtables hostapd-utils wifitoggle wpad ip-full kmod-ath10k kmod-leds-gpio \
- kmod-ledtrig-gpio
-endef
-
-define Profile/dLAN_pro_1200_ac/Description
- Package set optimized for the devolo dLAN pro 1200+ WiFi ac.
-endef
-$(eval $(call Profile,dLAN_pro_1200_ac))