summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/files/arch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2008-11-25 19:19:55 +0000
committerGabor Juhos <juhosg@openwrt.org>2008-11-25 19:19:55 +0000
commit4690f9356c88207a5b91f4dbd0618e5eb14f62b1 (patch)
tree1df62f15e4c016b140f178782c69a024490164bf /target/linux/ar71xx/files/arch
parent507b9818c0dadae940e68d711b643d6b732a2cea (diff)
downloadmaster-31e0f0ae-4690f9356c88207a5b91f4dbd0618e5eb14f62b1.tar.gz
master-31e0f0ae-4690f9356c88207a5b91f4dbd0618e5eb14f62b1.tar.bz2
master-31e0f0ae-4690f9356c88207a5b91f4dbd0618e5eb14f62b1.zip
add dummy code for the Atheros AP83 board
SVN-Revision: 13354
Diffstat (limited to 'target/linux/ar71xx/files/arch')
-rw-r--r--target/linux/ar71xx/files/arch/mips/ar71xx/Kconfig4
-rw-r--r--target/linux/ar71xx/files/arch/mips/ar71xx/Makefile1
-rw-r--r--target/linux/ar71xx/files/arch/mips/ar71xx/mach-ap83.c24
3 files changed, 29 insertions, 0 deletions
diff --git a/target/linux/ar71xx/files/arch/mips/ar71xx/Kconfig b/target/linux/ar71xx/files/arch/mips/ar71xx/Kconfig
index d8ae08577b..3b11057a6b 100644
--- a/target/linux/ar71xx/files/arch/mips/ar71xx/Kconfig
+++ b/target/linux/ar71xx/files/arch/mips/ar71xx/Kconfig
@@ -6,6 +6,10 @@ config AR71XX_EARLY_SERIAL
menu "Atheros AR71xx machine selection"
+config AR71XX_MACH_AP83
+ bool "Atheros AP83 board support"
+ default y
+
config AR71XX_MACH_AW_NR580
bool "AzureWave AW-NR580 board support"
default y
diff --git a/target/linux/ar71xx/files/arch/mips/ar71xx/Makefile b/target/linux/ar71xx/files/arch/mips/ar71xx/Makefile
index 175c43e911..dc682c8e57 100644
--- a/target/linux/ar71xx/files/arch/mips/ar71xx/Makefile
+++ b/target/linux/ar71xx/files/arch/mips/ar71xx/Makefile
@@ -10,6 +10,7 @@
obj-y := prom.o irq.o setup.o platform.o gpio.o ar71xx.o
+obj-$(CONFIG_AR71XX_MACH_AP83) += mach-ap83.o
obj-$(CONFIG_AR71XX_MACH_AW_NR580) += mach-aw-nr580.o
obj-$(CONFIG_AR71XX_MACH_GENERIC) += mach-generic.o
obj-$(CONFIG_AR71XX_MACH_RB_4XX) += mach-rb-4xx.o
diff --git a/target/linux/ar71xx/files/arch/mips/ar71xx/mach-ap83.c b/target/linux/ar71xx/files/arch/mips/ar71xx/mach-ap83.c
new file mode 100644
index 0000000000..02e420ade2
--- /dev/null
+++ b/target/linux/ar71xx/files/arch/mips/ar71xx/mach-ap83.c
@@ -0,0 +1,24 @@
+/*
+ * Atheros AP83 board support
+ *
+ * Copyright (C) 2008 Gabor Juhos <juhosg@openwrt.org>
+ * Copyright (C) 2008 Imre Kaloz <kaloz@openwrt.org>
+ *
+ * This program is free software; you can redistribute it and/or modify it
+ * under the terms of the GNU General Public License version 2 as published
+ * by the Free Software Foundation.
+ */
+
+#include <linux/platform_device.h>
+#include <linux/input.h>
+
+#include <asm/mips_machine.h>
+#include <asm/mach-ar71xx/ar71xx.h>
+#include <asm/mach-ar71xx/pci.h>
+#include <asm/mach-ar71xx/platform.h>
+
+static void __init ap83_setup(void)
+{
+}
+
+MIPS_MACHINE(MACH_AR71XX_AP83, "Atheros AP83", ap83_setup);