summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/files/arch/mips/ath79/Makefile
diff options
context:
space:
mode:
authorPiotr Dymacz <pepe2k@gmail.com>2016-06-16 18:08:03 +0200
committerJo-Philipp Wich <jo@mein.io>2016-07-13 20:03:10 +0200
commite767980eb897fbefc320f97b65944ce690ed1726 (patch)
treece2c26804d1b36d2b878d242b56b04666e5a2e69 /target/linux/ar71xx/files/arch/mips/ath79/Makefile
parent3c6b091b65da47286ba4fc81d409023bdcf42629 (diff)
downloadmaster-31e0f0ae-e767980eb897fbefc320f97b65944ce690ed1726.tar.gz
master-31e0f0ae-e767980eb897fbefc320f97b65944ce690ed1726.tar.bz2
master-31e0f0ae-e767980eb897fbefc320f97b65944ce690ed1726.zip
ar71xx: add support for Wallys DR531
Wallys DR531 is based on Qualcomm Atheros QCA9531 v2. Short specification: - 550/400/200 MHz (CPU/DDR/AHB) - 2x 10/100 Mbps Ethernet - 64 MB of RAM (DDR2) - 8 MB of FLASH - 2T2R 2.4 GHz with external PA (SE2576L), up to 30 dBm - 2x MMCX connectors - mini-PCIe connector with PCIe/USB buses and SIM slot - 7x LED, 1x button, 1x optional buzzer - UART, (E)JTAG and LED headers Default configuration: - WAN on eth1 (RJ45 near DC jack) - LAN on eth0 (RJ45 near button) - S4 LED set to be status LED - all LEDs configurable form user space - button configured for reset Flash instruction (do it under U-Boot, using UART): 1. tftp 0x80060000 lede-ar71xx-generic-dr531-squashfs-sysupgrade.bin 2. erase 0x9f050000 +$filesize 3. cp.b $fileaddr 0x9f050000 $filesize 4. setenv bootcmd "bootm 0x9f050000" 5. saveenv && reset Signed-off-by: Piotr Dymacz <pepe2k@gmail.com>
Diffstat (limited to 'target/linux/ar71xx/files/arch/mips/ath79/Makefile')
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/Makefile b/target/linux/ar71xx/files/arch/mips/ath79/Makefile
index f8b0b2bb5a..33c274fcc4 100644
--- a/target/linux/ar71xx/files/arch/mips/ath79/Makefile
+++ b/target/linux/ar71xx/files/arch/mips/ath79/Makefile
@@ -80,6 +80,7 @@ obj-$(CONFIG_ATH79_MACH_DIR_615_I1) += mach-dir-615-i1.o
obj-$(CONFIG_ATH79_MACH_DIR_825_B1) += mach-dir-825-b1.o
obj-$(CONFIG_ATH79_MACH_DIR_825_C1) += mach-dir-825-c1.o
obj-$(CONFIG_ATH79_MACH_DR344) += mach-dr344.o
+obj-$(CONFIG_ATH79_MACH_DR531) += mach-dr531.o
obj-$(CONFIG_ATH79_MACH_DRAGINO2) += mach-dragino2.o
obj-$(CONFIG_ATH79_MACH_ESR900) += mach-esr900.o
obj-$(CONFIG_ATH79_MACH_EW_DORIN) += mach-ew-dorin.o